【PAT】乙级 1054 求平均值 (20 分) c++

1054 求平均值 (20 分)

本题的基本要求非常简单:给定 N 个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是 [−1000,1000] 区间内的实数,并且最多精确到小数点后 2 位。当你计算平均值的时候,不能把那些非法的数据算在内。

输入格式:
输入第一行给出正整数 N(≤100)。随后一行给出 N 个实数,数字间以一个空格分隔。

输出格式:
对每个非法输入,在一行中输出 ERROR: X is not a legal number,其中 X 是输入。最后在一行中输出结果:The average of K numbers is Y,其中 K 是合法输入的个数,Y 是它们的平均值,精确到小数点后 2 位。如果平均值无法计算,则用 Undefined 替换 Y。如果 K 为 1,则输出 The average of 1 number is Y。

输入样例 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

输出样例 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

输入样例 2:

2
aaa -9999

输出样例 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

示例代码:

#include<iostream> 
#include<string>
using namespace std;
bool judgeIsNum(char c){//判断是否为数字 
	if(c-'0'<10&&c-'0'>=0){
		return true;
	}
	return false;
}
int main(){
	int N;
	string str;
	cin>>N;
	double sum=0;
	int numcount=0;
	for(int i=0;i<N;i++){
		cin>>str;
		int pointFlag=0;
		int fcount=0;//计算小数点位数 
		int j;
		for(j=0;j<str.size();j++){
			if(pointFlag==1)
				fcount++;//计算小数点位数 	
			if(fcount>2){break;}
			if(pointFlag==0&&str[j]=='.'&&j!=0){	
				pointFlag=1;//小数点存在的标志 
			}else if(judgeIsNum(str[j])||(j==0&&str[j]=='-')){
			}else {
				break; 
			}
		}
		
		if(j>=str.size()){
			double fNumber = stod(str) ;
			if(fNumber<=1000&&fNumber>=-1000){
				sum=fNumber+sum;
				numcount++;		
			}else{
				cout<<"ERROR: "<<str<<" is not a legal number"<<endl;
			}
		}else{
			cout<<"ERROR: "<<str<<" is not a legal number"<<endl;
		}
	}
	
	cout<<"The average of "<<numcount<<" number";
	if(numcount!=1)
		cout<<"s"; 
	cout<<" is ";
	
	if(numcount>0)
		printf("%.2lf",sum/double(numcount));		
	else
		cout<<"Undefined";
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值