【POJ - 1703】Find them, Catch them(带权并查集之--种类并查集 权为与父节点关系)

题干:

                                                      Find them, Catch them

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 36176 Accepted: 11090

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

题目大意:

是一个城市有两个帮派,A 1 2是询问1和2这两个人是不是一个帮派,D 1 2是认为这两个人不在一个帮派是true的(即认为他俩不在一个帮派) 每一次A就输出一次 思路: 带权并查集,加一个数组rank[]表示子节点和其父节点的关系,是一个门派就是0,不是就是1

(ps:用G++语言提交,不让用rank做数组名,,也是很不友好的)

解题报告:

     这题是带权并查集的一个变种,叫做种类并查集,上一次训练的题有一个虫子谈恋爱的,判断是不是同性恋(POJ - 2492),还有最经典的种类并查集食物链,都是种类并查集,权均代表与祖先节点之间的关系。使用的一种向量思维把各种给定的情况用权值分开表示。比如此题rank[0]代表与祖先节点是同一帮派,rank[1]代表与祖先节点是不同帮派。

AC代码1:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;
const int MAX = 1e5 + 5;
int n,m;
bool rank[MAX];
int f[MAX];
int getf(int v) {
	if(f[v] == v) return v;
	int tmp=f[v];
	f[v] = getf(f[v] );
	rank[v] = (rank[v] + rank[tmp] ) %2;
	return f[v];
}
void merge(int u,int v) {
	int t1 = getf(u);
	int t2 = getf(v);
	if(t1!=t2) {
		f[t2] = t1;
		rank[t2] = (rank[u]+rank[v]+1)%2;//放到if外面可以吗   应该不行吧   你让老大和自己的关系 通过u和v这两个小喽啰来改变?应该不行吧,,要改变这个老大的rank 只能让更老大的巨擘来当这个老大的头头。然后rank跟着巨擘来改变。 
	}
}
void init() {
	for(int i = 1; i<=n; i++) {
		f[i]=i;
		rank[i]=0;
	}
}
int main()
{
	int t;
	char op[5];
	cin>>t;
	while(t--) {
		int u,v; 
 		scanf("%d %d",&n,&m);
 		init();
		while(m--) {
			scanf("%s",op);
			scanf("%d %d",&u,&v);
			if(op[0] == 'D') {
				merge(u,v); 
			}
			else {
				if(getf(u) != getf(v) ) printf("Not sure yet.\n");
				else {
					if(rank[u]==rank[v]) printf("In the same gang.\n");
					else printf("In different gangs.\n");
				}	
			}
		} 	
	}	
	return 0 ;
 }

总结:

    1. emmm 别忘了输出最后的句点哈、、、、

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值