ACM竞赛、数论内容常用的定理(求解(a/b)%c,乘法逆元,费马小定理)

38 篇文章 0 订阅

如果b与c互素,则(a/b)%c=a*b^(\Phi(c)-1)%c其中\Phi是欧拉函数。或者(a/b)%c=a*b^(c-2)%c

如果b与c不互素,则(a/b)%c=(a%bc)/b

对于b与c互素和不互素都有(a/b)%c=(a%bc)/b成立

乘法逆元用扩展欧几里得定理:

例题:ZOJ - 3609

题干:

The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1≡x (mod m). This is equivalent to ax≡1 (mod m).

Input

There are multiple test cases. The first line of input is an integer T ≈ 2000 indicating the number of test cases.

Each test case contains two integers 0 < a ≤ 1000 and 0 < m ≤ 1000.

Output

For each test case, output the smallest positive x. If such x doesn't exist, output "Not Exist".

Sample Input

3

3 11

4 12

5 13

Sample Output
4

Not Exist

8

题目大意:如果存在逆元输出逆元,不存在逆元输出Not Exist。

AC代码:

#include<bits/stdc++.h>
#define ll long long
using namespace std;

int e_gcd(int a,int b,int &x,int &y) {
	if(b == 0) {
		x=1;y=0;return a;
	}
	int q=e_gcd(b,a%b,y,x);
	y-=a/b*x;
	return q;
}
int main()
{
	long long t;
	int x,y,a,b;
	while(~scanf("%lld",&t) ) {
		while(t--) {
			scanf("%d%d",&a,&b);
			int gcd = e_gcd(a,b,x,y);
			if(gcd !=1) {
				puts("Not Exist");
				continue;	
			}
			if(x<=0) x+=b;
			printf("%d\n",x);	
		}
		
	}
	
	return 0 ;
}

 

注意一下是x<=0的时候都不算逆元!!需要x+=b来变成正数!不能是非负数!。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值