【HDU - 6016】Count the Sheep (思维,类似二分图)

230 篇文章 1 订阅
26 篇文章 0 订阅

题干:

Altough Skipping the class is happy, the new term still can drive luras anxious which is of course because of the tests! Luras became worried as she wanted to skip the class, as well as to attend the BestCoder and also to prepare for tests at the same time. 

However, As the result of preparing for tests, luras had no time to practice programing. She didn't want to lose her rating after attending BC. In the end, she found BCround92's writer snowy_smile for help, asking him to leak her something. 

Snowy_smile wanted to help while not leaking the problems. He told luras, the best thing to do is to take a good rest according to the following instructions first. 

"Imagine you are on the endless grassland where there are a group of sheep. And n sheep of them are silent boy-sheep while m sheep are crying girl-sheep. And there are k friend-relationships between the boy-sheep and girl-sheep.Now You can start from any sheep, keep counting along the friend relationship. If you can count 4 different sheep, you will exceed 99% sheep-counters and fall asleep." 

Hearing of the strange instructions, luras got very shocked. Still, she kept counting. Sure enough, she fell asleep after counting 4 different sheep immediately. And, she overslept and missed the BestCoder in the next day. At a result, she made it that not losing her rating in the BCround92!!! 

However, you don't have the same good luck as her. Since you have seen the 2nd problem, you are possible to have submitted the 1st problem and you can't go back. 

So, you have got into an awkward position. If you don't AC this problem, your rating might fall down. 

You question is here, please, can you tell that how many different 4-sheep-counting way luras might have before her sleep? 

In another word, you need to print the number of the "A-B-C-D" sequence, where A-B, B-C, C-D are friends and A,B,C,D are different.

Input

The first line is an integer T which indicates the case number. 

and as for each case, there are 3 integers in the first line which indicate boy-sheep-number, girl-sheep-number and friend-realationship-number respectively. 

Then there are k lines with 2 integers x and y in each line, which means the x-th boy-sheep and the y-th girl-sheep are friends. 

It is guaranteed that—— 

There will not be multiple same relationships. 

1 <= T <= 1000 

for 30% cases, 1 <= n, m, k <= 100 

for 99% cases, 1 <= n, m, k <= 1000 

for 100% cases, 1 <= n, m, k <= 100000

Output

As for each case, you need to output a single line. 

there should be 1 integer in the line which represents the number of the counting way of 4-sheep-sequence before luras's sleep.

Sample Input

3
2 2 4
1 1
1 2
2 1
2 2
3 1 3
1 1
2 1
3 1
3 3 3
1 1
2 1
2 2

Sample Output

8
0
2

题目大意:

有一堆公羊和母羊,给定K个关系(一定是公羊和母羊的关系),让你找出从里面任意一头开始找。找到四头不同的羊。为你一共有多少种找法。(1 <= n, m, k <= 100000)

解题报告:

      给出很多对 雄羊雌羊的朋友关系,让你数数,能数出几种关系,关系中的四只羊不能有重复的。相当于四只羊中间有三条边,遍历中间那条边即可,最后答案再乘2,因为反过来也是成立的。

AC代码

#include<cstdio>
#include<queue>
#include<cstring>
#include<cmath>
#include<map>
#include<iostream>
#include<algorithm>
#define ll long long
using namespace std;
const int MAX = 100000 +5;
struct Edge {
	int u,v;
	Edge(){}
	Edge(int u,int v):u(u),v(v){} 
} e[MAX];
ll mile[MAX],femile[MAX];
int top;
int main()
{
	int t;
	int n,m,k,a,b;
	cin>>t;
	while(t--) {
		top = 0;
		memset(mile,0,sizeof mile);
		memset(femile,0,sizeof femile);
		scanf("%d%d%d",&n,&m,&k);
		for(int i = 1; i<=k; i++) {
			scanf("%d%d",&a,&b);
			e[++top] = Edge(a,b);
			mile[a]++;
			femile[b]++;
		}
		ll ans = 0;
		for(int i = 1; i<=top; i++) {
			ans += (mile[e[i].u]-1) * (femile[e[i].v] - 1);
		}
		printf("%lld\n",ans*2);
	}

	return 0 ;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值