【HDU - 4185】Oil Skimming (二分图,建图,匈牙利算法)

26 篇文章 0 订阅
13 篇文章 0 订阅

题干:

Thanks to a certain "green" resources company, there is a new profitable industry of oil skimming. There are large slicks of crude oil floating in the Gulf of Mexico just waiting to be scooped up by enterprising oil barons. One such oil baron has a special plane that can skim the surface of the water collecting oil on the water's surface. However, each scoop covers a 10m by 20m rectangle (going either east/west or north/south). It also requires that the rectangle be completely covered in oil, otherwise the product is contaminated by pure ocean water and thus unprofitable! Given a map of an oil slick, the oil baron would like you to compute the maximum number of scoops that may be extracted. The map is an NxN grid where each cell represents a 10m square of water, and each cell is marked as either being covered in oil or pure water.

Input

The input starts with an integer K (1 <= K <= 100) indicating the number of cases. Each case starts with an integer N (1 <= N <= 600) indicating the size of the square grid. Each of the following N lines contains N characters that represent the cells of a row in the grid. A character of '#' represents an oily cell, and a character of '.' represents a pure water cell.

Output

For each case, one line should be produced, formatted exactly as follows: "Case X: M" where X is the case number (starting from 1) and M is the maximum number of scoops of oil that may be extracted.

Sample Input

1
6
......
.##...
.##...
....#.
....##
......

Sample Output

Case 1: 3

题目大意:

有一个地图,' . '代表水,' # ' 代表油。每个单元格是10*10的,现用一个'.'或'#'表示,现有10*20的勺子可以提取出水上漂浮的油,问最多可以提取几勺的油; 每次提取的时候勺子放的位置都要是油,不然就被海水污染而没有价值了。

一句话题意:每次恰好覆盖相邻的两个#,不能重复,求最大覆盖次数。

解题报告:

   建模:用模板每次恰好覆盖相邻的两个#,同一个点不能重复覆盖,求最大覆盖次数。

  建图:这题有两种建图方式。一种是奇偶建图,即(i+j)的奇偶数来建图,vis1表示左侧集合,vis2表示右侧。因为木板能且仅能只能放在(i+j)%2==0 和 (i+j)%2==1这两个相邻的位置上,所以我们这么去分集合。然后找匹配就可以了。

             第二种建图方式就是如果是'#'那就++cnt,就是都用同一套体系来给‘#’标号,这样最后匈牙利搞完之后答案/2即可。

下面分别给出代码。

建图方式1的AC代码:

#include<bits/stdc++.h>
using namespace std;
int n,ans;
int vis1[605][605],vis2[605][605],line[605][605];
bool used[605*605];
char maze[605][605];
int tot1,tot2;
int nxt[605*605];
bool find(int x) {
	for(int i = 1; i<=tot2; i++) {
		if(line[x][i] && !used[i]) {
			used[i]=1;
			if(nxt[i] == 0 || find(nxt[i])) {
				nxt[i] = x;
				return 1;
			}
		}
	}
	return 0 ;
}
int match() {
	int sum = 0;
	memset(nxt,0,sizeof nxt);
	for(int i = 1; i<=tot1; i++) {
		memset(used,0,sizeof used);
		if(find(i)) sum++;
	}
	return sum;
}
int main() 
{
	int iCase = 0,t=0;
	scanf("%d",&t);
	while(t--) {
		tot1 = tot2 = 0;
		scanf("%d",&n);
		memset(vis1,0,sizeof vis1);
		memset(vis2,0,sizeof vis2);
		memset(line,0,sizeof line);
		for(int i = 1; i<=n; i++) {
			scanf("%s",maze[i]+1);
		}
		for(int i = 1; i<=n; i++) {
			for(int j = 1; j<=n; j++) {
				if(maze[i][j] == '#') {
					if((i+j)&1) vis2[i][j] = ++tot2;
					else vis1[i][j] = ++tot1;
				}
			}
		}
		for(int i = 1; i<=n; i++) {
			for(int j = 1; j<=n; j++) {
				if((i+j)&1) continue;
				if(maze[i][j] == '#') {
					if(maze[i][j+1] == '#' && j+1 <= n) line[vis1[i][j]][vis2[i][j+1]]=1;
					if(maze[i][j-1] == '#' && j-1 >= 1) line[vis1[i][j]][vis2[i][j-1]]=1;
					if(maze[i+1][j] == '#' && i+1 <= n) line[vis1[i][j]][vis2[i+1][j]]=1;
					if(maze[i-1][j] == '#' && i-1 >= 1) line[vis1[i][j]][vis2[i-1][j]]=1;
				}
			}
		}
		
		printf("Case %d: %d\n",++iCase,match());
	}

	return 0 ;
}

建图方式2的AC代码:

#include<bits/stdc++.h>
using namespace std;
int n,ans;
int vis[605][605],line[605][605];
bool used[605*605];
char maze[605][605];
int tot;
int nxt[605*605];
bool find(int x) {
	for(int i = 1; i<=tot; i++) {
		if(line[x][i] && !used[i]) {
			used[i]=1;
			if(nxt[i] == 0 || find(nxt[i])) {
				nxt[i] = x;
				return 1;
			}
		}
	}
	return 0 ;
}
int match() {
	int sum = 0;
	memset(nxt,0,sizeof nxt);
	for(int i = 1; i<=tot; i++) {
		memset(used,0,sizeof used);
		if(find(i)) sum++;
	}
	return sum;
}
int main() 
{
	int iCase = 0,t=0;
	scanf("%d",&t);
	while(t--) {
//		tot1 = tot2 = 0;
		tot=0;
		scanf("%d",&n);
		memset(vis,0,sizeof vis);
		memset(line,0,sizeof line);
		for(int i = 1; i<=n; i++) {
			scanf("%s",maze[i]+1);
		}
		for(int i = 1; i<=n; i++) {
			for(int j = 1; j<=n; j++) {
				if(maze[i][j] == '#') {
					vis[i][j] = ++tot;
				}
			}
		}
		for(int i = 1; i<=n; i++) {
			for(int j = 1; j<=n; j++) {
				if(maze[i][j] == '#') {
					if(maze[i][j+1] == '#' && j+1 <= n) line[vis[i][j]][vis[i][j+1]]=1;
					if(maze[i][j-1] == '#' && j-1 >= 1) line[vis[i][j]][vis[i][j-1]]=1;
					if(maze[i+1][j] == '#' && i+1 <= n) line[vis[i][j]][vis[i+1][j]]=1;
					if(maze[i-1][j] == '#' && i-1 >= 1) line[vis[i][j]][vis[i-1][j]]=1;
				}
			}
		}
		printf("Case %d: %d\n",++iCase,match()/2);
	}

	return 0 ;
}

总结:

   再好好想想建图!和POJ - 2226这个最小点覆盖的题比较一下,也是写过博客的。这俩题还是有共同之处的。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值