【HDU - 1102】Constructing Roads (最小生成树裸题模板)

题干:

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum. 

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j. 

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built. 

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

题目大意:

  大概意思就是给你一个图,然后告诉你每两个点之间的距离,然后给你一个q,下面q行,每行两个数代表这两个点是连通的,问你为了让整个图是个连通图,最短还需要修多长的路。

解题报告:

  最小生成树裸题,,复习一下,,不解释了、、最后就是,加不加那个cnt计数对这道题都无所谓,因为数据量太小了,都是31ms。下面两个代码都贴上。

AC代码:(加cnt计数)

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define ll long long
#define pb push_back
#define pm make_pair
#define fi first
#define se second
using namespace std;
const int MAX = 2e5 + 5;
int n,tot;
int f[205];
struct Edge {
	int u,v;
	int w;
	Edge(){}
	Edge(int u,int v,int w):u(u),v(v),w(w){}
} e[MAX<<1];
bool cmp(Edge a,Edge b) {
	return a.w < b.w;
}
int getf(int v) {
	return f[v] == v ? v : f[v] = getf(f[v]);
}
void merge(int u,int v) {
	int t1 = getf(u);
	int t2 = getf(v);
	if(t1!=t2) f[t2]=t1;
} 
int main()
{
	while(~scanf("%d",&n)) {
		tot=0;
		for(int i = 1; i<=n; i++) f[i] = i;
		for(int i = 1,w; i<=n; i++) {
			for(int j = 1; j<=n; j++) {
				scanf("%d",&w);
				if(i==j) continue;
				e[++tot] = Edge(i,j,w);
				e[++tot] = Edge(j,i,w);
			}
		}	
		int q,cnt = 0;
		scanf("%d",&q);
		while(q--) {
			int u,v;
			scanf("%d%d",&u,&v);
			if(getf(u)!=getf(v)) merge(u,v),cnt++;
		}
		sort(e+1,e+tot+1,cmp);
		ll ans = 0;
		for(int i = 1; i<=tot; i++) {
			int u = e[i].u,v = e[i].v;
			if(getf(u) == getf(v)) continue;
			merge(u,v);cnt++;
			ans += 1LL * e[i].w;
			if(cnt == n-1) break;
		}
		printf("%lld\n",ans);
	}
	return 0 ;
 }

AC代码2:(不加cnt计数)

//不带cnt计数  版本
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define ll long long
#define pb push_back
#define pm make_pair
#define fi first
#define se second
using namespace std;
const int MAX = 2e5 + 5;
int n,tot;
int f[205];
struct Edge {
	int u,v;
	int w;
	Edge(){}
	Edge(int u,int v,int w):u(u),v(v),w(w){}
} e[MAX<<1];
bool cmp(Edge a,Edge b) {
	return a.w < b.w;
}
int getf(int v) {
	return f[v] == v ? v : f[v] = getf(f[v]);
}
void merge(int u,int v) {
	int t1 = getf(u);
	int t2 = getf(v);
	if(t1!=t2) f[t2]=t1;
} 
int main()
{
	while(~scanf("%d",&n)) {
		tot=0;
		for(int i = 1; i<=n; i++) f[i] = i;
		for(int i = 1,w; i<=n; i++) {
			for(int j = 1; j<=n; j++) {
				scanf("%d",&w);
				if(i==j) continue;
				e[++tot] = Edge(i,j,w);
				e[++tot] = Edge(j,i,w);
			}
		}	
		int q;
		scanf("%d",&q);
		while(q--) {
			int u,v;
			scanf("%d%d",&u,&v);
			merge(u,v);
		}
		sort(e+1,e+tot+1,cmp);
		ll ans = 0;
		for(int i = 1; i<=tot; i++) {
			int u = e[i].u,v = e[i].v;
			if(getf(u) == getf(v)) continue;
			merge(u,v);
			ans += 1LL * e[i].w;
		}
		printf("%lld\n",ans);
	}
	return 0 ;
 }

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值