1108 Finding Average (20 分)

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legalinput is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2:

2
aaa -9999

Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

题目大意:给出一组数据,判断输出是不是合法数字(精度不超过小数点后两位,范围【-1000,1000】),有合法数据还要累加算出average;不存在合法数据输出The average of 0 numbers is Undefined

分析:这道题要是常规做法string读入,一个个判断小数点和精度啥的肯定代码很长。

遂这里采用sscanf()和sprintf()函数

函数原型:int sscanf ( const char * s, const char * format, ...);

str - - 一个C字符串表示需要得到数据的数据源。
format - - 一个C字符串表示数据的输入格式,可以参照scanf的形式。

函数支持正则表达式。

函数原型:int sprintf ( char * str, const char * format, ... );

str - - 用于指向一个C字符数组的指针,这个字符数组的大小应足以容纳需要放入变量的总长度。
format - - 格式字符串,用于指示放入 str 的变量的格式。(可以参照 printf)。

例如:

sscanf(a,"%lf",&temp); //将temp以double读入a中
sprintf(b,"%.2f",temp);//temp按%.2f写到b

下面只需要按位比较a与b即可。

AC代码:

#include<bits/stdc++.h>
using namespace std;

int main(){
	int n;
	cin>>n;
	char a[50],b[50];
	double temp,sum=0.0;
	int cnt=0;
	for(int i=0;i<n;i++){
		scanf("%s",a);
		sscanf(a,"%lf",&temp);
		sprintf(b,"%.2f",temp);
		bool flag=false;
		for(int j=0;j<strlen(a);j++)
		   if(a[j]!=b[j]) flag=true;
		if(flag || temp<-1000 || temp>1000){
				printf("ERROR: %s is not a legal number\n",a);
				continue;
			}else{
				sum+=temp;
				cnt++;
			}
		}
	if(cnt == 1)  
		printf("The average of 1 number is %.2f", sum);
    else if(cnt > 1)
        printf("The average of %d numbers is %.2f", cnt, sum / cnt);
    else
        printf("The average of 0 numbers is Undefined");
    return 0;
}		

End!

  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZCAIHUI_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值