1115 Counting Nodes in a BST (30 point(s))(创建BST,DFS统计每层结点个数)

1115 Counting Nodes in a BST (30 point(s))

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than or equal to the node's key.
  • The right subtree of a node contains only nodes with keys greater than the node's key.
  • Both the left and right subtrees must also be binary search trees.

Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000) which is the size of the input sequence. Then given in the next line are the Nintegers in [−10001000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:

9
25 30 42 16 20 20 35 -5 28

Sample Output:

2 + 4 = 6

题目大意:题目所给序列创建一颗BST,求出最后两层的结点个数,输出n1 + n2 = n的形式

思路:所给序列直接建树,然后深度遍历,遍历过程中统计每一层结点个数。

写法一:二叉链表建BST+深搜

#include <bits/stdc++.h>
using namespace std;
struct node{
	int data;
	node *left,*right;
};

node *insert(node *&root,int val){
	if(!root){
		root=new node;
		root->data =val;
		root->left =root->right =NULL;
		return root;
	}else if(root->data >=val)
	    return insert(root->left,val);
	 else 
	    return insert(root->right ,val);
}
		
vector<int> num(1000);
int maxdepth = -1;
void DFS(node *root, int depth) {
    if(!root) {
        maxdepth = max(depth, maxdepth);
        return ;
    }
	num[depth]++;
  //  if(!root) return ;
    DFS(root->left, depth + 1);
    DFS(root->right, depth + 1);
}

int main(){
	int n,val;
	cin>>n;
	node *root=NULL;
	for(int i=0;i<n;i++){
		cin>>val;
		insert(root,val);
	} 
	DFS(root,0);
	inorder(root);
    printf("%d + %d = %d\n",num[maxdepth-1],num[maxdepth-2],num[maxdepth-2]+num[maxdepth-1]);
	return 0;
} 

写法二:数组建立BST+深搜

#include<bit/stdc++.h>
using namespace std;
int tree[1005][2];
int num[1005];
int root;
void insert(int &root,int y){
	if(!root){
		root=y;
		return;
	}
	else if(num[y]<=num[root]){
		insert(tree[root][0],y);
	}
	else{
		insert(tree[root][1],y);
	}
}

vector<int> v(1000);
int maxdepth = -1;
void DFS(int root, int depth) {
    if(!root) {
        maxdepth = max(depth, maxdepth);
        return ;
    }
    v[depth]++;
    DFS(tree[root][0], depth + 1);
    DFS(tree[root][1], depth + 1);
}

int main(){
	int n;
	cin>>n;
	for(int i=1;i<=n;i++){// 下标从1开始 ,因为insert里是if(!root)
		cin>>num[i];
		insert(root,i);
	}
	DFS(root,0);
	printf("%d + %d = %d\n",v[maxdepth-1],v[maxdepth-2],v[maxdepth-1]+v[maxdepth-2]);
	return 0;
}

广度遍历访问结点方便,但统计每层的结点个数不如深搜效果好,这里推荐深搜。

上一题:1099 Build A Binary Search Tree (30 point(s))

https://blog.csdn.net/qq_41317652/article/details/88961934

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZCAIHUI_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值