1099 Build A Binary Search Tree (30 point(s))

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

figBST.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

题目大意:给定二叉树形态,给你一组数据让你填充二叉树,使之符合搜索二叉树的定义,然后输出此搜索二叉树的层次遍历。

方法一:采用静态链表的+排序

分析:题目最终是构建了一颗BST,而BST的中序遍历是递增序列,因此可以先将给定填充序列进行sort排序。由于题目给出的二叉树是N个结点的索引方式,因此结点结构采用静态二叉链表实现非常方便,也就是左右指针域用int代替。然后中序遍历填充二叉树的node结点。最后对node结点进行排序(层次优先级lay大于值val的优先级)输出即可。

//树的静态链表写法,结点内存放孩子下标索引 
#include <bits/stdc++.h>
using namespace std;
const int N=101;
int cnt,b[N];
struct Node{
	int val,l,r,lay;
}node[N];

bool cmp(Node a,Node b){
	if(a.lay !=b.lay ) return a.lay <b.lay ;
	else return a.val <b.val ;
}

void DFS(int root,int layor){
	if(node[root].l ==-1 && node[root].r ==-1){
		node[root]={b[cnt++],node[root].l,node[root].r,layor};	
	}else{
		if (node[root].l != -1) DFS(node[root].l,layor+1);
		node[root]={b[cnt++],node[root].l,node[root].r,layor};
		if(node[root].r!=-1 )DFS(node[root].r,layor+1);
	}
}

int main(){
	int n;
	cin>>n;
	for(int i=0;i<n;i++)
		cin>>node[i].l >>node[i].r;
	for(int i=0;i<n;i++) cin>>b[i];
	sort(b,b+n);
	DFS(0,0);
	sort(node,node+n,cmp);
	for(int i=0;i<n;i++)
		printf("%d%s",node[i].val,i!=n-1? " ":"\n" );
	return 0;
}

方法二:采用二叉链表+BFS广搜

分析:采用二叉链表没有静态链表简单,因为这种结构体定义的时候没有左右结点的索引编号,只能先根据读入的二叉链表形态创建根节点与左右孩子的关系,进而构建一颗完整的二叉树。然后中序遍历填充二叉树,最后层次遍历输出目的序列。

#include <bits/stdc++.h>
using namespace std;
const int N=101;
int cnt,b[N];
struct Node{
	int val;
	Node *left,*right;
};Node *node[N]={0};

void Inorder(Node *root){
    if (!root) return;
    Inorder(root->left);
    root->val = b[cnt++];
    Inorder(root->right);
}

Node *CreateTree(int n){
    for (int i = 0; i < n; ++i){
        node[i] = new Node;
        node[i]->left = node[i]->right = NULL;
    }
    for (int i = 0; i < n; ++i){
        int id_l,id_r;
        cin >> id_l>>id_r;
        if (id_l != -1)
            node[i]->left=node[id_l];
        if (id_r!= -1)
            node[i]->right=node[id_r];
    }
    return node[0];
}

void BFS(Node *root){
//	if(!root) return ;
	queue<Node*>q;
	q.push(root);
	bool flag=false;
	while(!q.empty()){
		Node *now=q.front();
		q.pop();
		printf("%s%d",flag==false? "":" ",now->val);
		flag=true;
		if(now->left!=NULL) q.push(now->left);
		if(now->right) q.push(now->right);
	}
}

int main(){
	int n;
	cin>>n;
	Node *root=CreateTree(n);
	for(int i=0;i<n;i++) cin>>b[i];
	sort(b,b+n);
	Inorder(root);
	BFS(root);
	return 0;
}

下一题:1151 LCA in a Binary Tree(30 point(s))

https://blog.csdn.net/qq_41317652/article/details/82557975

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZCAIHUI_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值