1053 Path of Equal Weight (30 point(s))

 

Given a non-empty tree with root R, and with weight W​i​​ assigned to each tree node T​i​​. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<2​30​​, the given weight number. The next line contains N positive numbers where W​i​​ (<1000) corresponds to the tree node T​i​​. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A​1​​,A​2​​,⋯,A​n​​} is said to be greater than sequence {B​1​​,B​2​​,⋯,B​m​​} if there exists 1≤k<min{n,m} such that A​i​​=B​i​​ for i=1,⋯,k, and A​k+1​​>B​k+1​​.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

题目大意:给一棵树和每个结点的权值。求所有从根到叶子结点的路径,使得每条路径上的结点的权值之和为给定常数S。若有多条,路径按非递增顺序输出。

思路:

1)树的读入:这是一颗普通的树,可能含有多叉。因此采用静态链表读入。结构体node存结点的数据域和指针域。指针域采用vector存放孩子结点编号。考虑到对路径输出时的要求,因此在读入每个结点的子节点vector时进行排序。

struct node{
	int val;
	vector<int>child;
}Node[MAXN];

bool cmp(int a,int b){
	return Node[a].val >Node[b].val ;
}

2)如何打印路径??(这里采用DFS递归)

1》确定DFS的参数

打印路径肯定得知道路径上结点的编号,这里开一个数组path【MAXN】用于保存路径上结点编号。递归是实时进行的那我得知道当前访问的结点编号,路径上已经访问了几个结点以及当前路径上的权值的累加和。因此DFS有三个参数:当前访问的结点编号index,当前路径path上的结点个数numNode以及当前路径上的权值和sum。

2》如何编写递归函数

1:递归边界:若 sum>S,直接 return。

                        若 sum==S,如果访问到叶子结点,则用path数组访问Node数组打印路径;若果未到达叶子节点,则return。

2:递归体:    若 sum < S,说明未满足要求,此时枚举index的所有子节点,对于每一个子节点child,先将其存入path【numNode】用于保存路径上结点编号,在此基础上向下一层递归,下一层参数为child,numNode=1,sum+Node[child].val;

void DFS(int index,int numNode,int sum){
	if(sum>S) return ;
	if(sum==S){
		if(Node[index].child.size()!=0) return ; // 非叶子,直接return 
		//到达叶子结点,则输出一条完整路径
		for(int i=0;i<numNode;i++){
			printf("%d",Node[path[i]].val );
			if(i<numNode-1) printf(" ");
			else printf("\n");
	    } 
	    return ;// 返回上一层 
    }
    for(int i=0;i<Node[index].child.size();i++){
    	int child=Node[index].child[i];
    	path[numNode]=child;//保存路径上结点编号 
    	DFS(child,numNode+1,sum+Node[child].val);
	}
}

如果打印的路径上结点编号,则直接在递归边界内输出符合要求的path【i】即可,若要统计路径个数,只需要开个 全局变量cnt,每产生一条合格路径进行cnt++即可。

完整代码:

#include<bits/stdc++.h>
using namespace std;
const int MAXN=1010;

struct node{
	int val;
	vector<int>child;
}Node[MAXN];

bool cmp(int a,int b){
	return Node[a].val >Node[b].val ;
}

int n,m,S;
int path[MAXN];

void DFS(int index,int numNode,int sum){
	if(sum>S) return ;
	if(sum==S){
		if(Node[index].child.size()!=0) return ; // 非叶子,直接return 
		//到达叶子结点,则输出一条完整路径
		for(int i=0;i<numNode;i++){
			printf("%d",Node[path[i]].val );
			if(i<numNode-1) printf(" ");
			else printf("\n");
	    } 
	    return ;// 返回上一层 
    }
    for(int i=0;i<Node[index].child.size();i++){
    	int child=Node[index].child[i];
    	path[numNode]=child;//保存路径上结点编号 
    	DFS(child,numNode+1,sum+Node[child].val);
	}
}
	
int main(){
	scanf("%d %d %d",&n,&m,&S);
	for(int i=0;i<n;i++) cin>>Node[i].val ;
	int id,k,child;
	for(int i=0;i<m;i++){ //读入树的结构 
		cin>>id>>k;
		for(int j=0;j<k;j++){
			cin>>child;
			Node[id].child.push_back(child);
		}
		sort(Node[id].child.begin(),Node[id].child.end(),cmp);
	}
	path[0]=0;
	DFS(0,1,Node[0].val);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZCAIHUI_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值