1126 Eulerian Path (25 point(s))

In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)

Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N (≤500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).

Output Specification:

For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph -- either EulerianSemi-Eulerian, or Non-Eulerian. Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

Sample Input 1:

7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6

Sample Output 1:

2 4 4 4 4 4 2
Eulerian

Sample Input 2:

6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6

Sample Output 2:

2 4 4 4 3 3
Semi-Eulerian

Sample Input 3:

5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3

Sample Output 3:

3 3 4 3 3
Non-Eulerian

题目大意:给你一个图,按1~N编号打印顶点的度,并判断是否具有欧拉回路。

判断标准:若所有结点的度都是偶数,说明是欧拉回路;

                  若恰好含有两个奇数结点,则是半欧拉回路

                  否则不是欧拉回路

分析:

1)给出的图不一定联通,先dfs深搜判断一下;

2)读入图的过程统计下结点的度,然后扫描记录记判断即可。

完整代码:

#include<bits/stdc++.h>
using namespace std;

int n,m;
bool vis[1000];
int degree[1000],G[1000][1000];
void dfs(int u){
	vis[u]=true;
	for(int v=1;v<=n;v++)
		if(vis[v]==false && G[u][v]==1)
			dfs(v);
} 

int main(){
	cin>>n>>m;
	for(int i=1;i<=m;i++){
		int a,b;
		cin>>a>>b;
		degree[a]++;
		degree[b]++;
		G[a][b]=G[b][a]=1;
	}
	int cnt1=0,cnt2=0;//分别记录度为偶数和奇数的结点个数 
	for(int i=1;i<=n;i++){
		if(i==1) cout<<degree[i];
		else cout<<" "<<degree[i];
		if(degree[i]%2==0) cnt1++;
		else cnt2++;
	}
	dfs(1);//深搜判断给定图是否是一个连通图
	bool flag=true;
	for(int i=1;i<=n;i++){
		if(!vis[i])
			flag=false;
	}
	if(!flag) cout<<"\nNon-Eulerian\n";
	else if(cnt1==n)
	        cout<<"\nEulerian\n";
	else if(cnt2==2) cout<<"\nSemi-Eulerian\n";  
	else    cout<<"\nNon-Eulerian\n";     
	return 0;
}

That's all !

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZCAIHUI_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值