Double Queue 用元素为结构体的set解决

Double Queue

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 1456    Accepted Submission(s): 734


 

Problem Description

The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provided by IBM Romania, and using modern information technologies. As usual, each client of the bank is identified by a positive integer K and, upon arriving to the bank for some services, he or she receives a positive integer priority P. One of the inventions of the young managers of the bank shocked the software engineer of the serving system. They proposed to break the tradition by sometimes calling the serving desk with the lowest priority instead of that with the highest priority. Thus, the system will receive the following types of request:

Your task is to help the software engineer of the bank by writing a program to implement the requested serving policy.
 

 

 

Input

Each line of the input contains one of the possible requests; only the last line contains the stop-request (code 0). You may assume that when there is a request to include a new client in the list (code 1), there is no other request in the list of the same client or with the same priority. An identifier K is always less than 106, and a priority P is less than 107. The client may arrive for being served multiple times, and each time may obtain a different priority.
 

 

 

Output

For each request with code 2 or 3, the program has to print, in a separate line of the standard output, the identifier of the served client. If the request arrives when the waiting list is empty, then the program prints zero (0) to the output.
 

 

 

Sample Input

 

2 1 20 14 1 30 3 2 1 10 99 3 2 2 0

 

 

Sample Output

 

0 20 30 10 0

 

 

Source

Southeastern Europe 2007

 

定义了三个操作

1:加入客户号和客户优先级

2:将当前优先级最高的客户移除

3:将当前优先级最低的客户移除

我用的是结构体,我居然用erase删除set的end(),程序异常输出,我找了一个小时,十分钟的题让我......,

另外,让迭代器减一会报错,需新生成一个迭代器,再赋给新的迭代器。

 

#include<iostream>
#include<cstdio>
#include<set>
#include<algorithm>
using namespace std;
struct kk
{
    int priority;
    int num;
};
bool operator < (const kk &x,const kk &y)
{
    return x.priority>y.priority;
}
int main()
{
    multiset<kk> w;
    kk s;
    s.num=0;
    s.priority=0;
    int i,j,t,n,m,k;
    w.clear();
    set<kk>::iterator id;
    while(~scanf("%d",&n),n)
    {
        if(n==1)
        {
            cin>>m>>t;
            s.num=m;
            s.priority=t;
            w.insert(s);
        }
        else if(n==2)
        {
            if(!w.empty())
            {
                cout<< (*(w.begin())).num<<endl;
                w.erase(w.begin());
            }
            else
            cout<<0<<endl;
            
        }
        else if(n==3)
        {
            id=w.end();
            id--;
            cout<<id->num<<endl;
            w.erase(id);
            
        }
        
    }
    
    
    return 0;
}

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
要定义一个元素结构体的队列,可以使用C语言的链式队列。具体来说,可以先定义一个结构体,然后再定义一个队列节点结构体,该节点结构体包含一个指向结构体的指针和一个指向下一个节点的指针。接着,定义一个队列结构体,该结构体包含一个指向队列头节点的指针和一个指向队列尾节点的指针。最后,可以定义一些基本的队列操作函数,例如入队、出队、获取队列大小等等。 以下是一个简单的示例代码: ```c #include <stdio.h> #include <stdlib.h> // 定义结构体 typedef struct { int id; char* name; } Element; // 定义队列节点结构体 typedef struct QueueNode { Element* data; struct QueueNode* next; } QueueNode; // 定义队列结构体 typedef struct { QueueNode* head; QueueNode* tail; int size; } Queue; // 初始化队列 void init(Queue* q) { q->head = NULL; q->tail = NULL; q->size = 0; } // 入队 void enqueue(Queue* q, Element* e) { QueueNode* node = (QueueNode*)malloc(sizeof(QueueNode)); node->data = e; node->next = NULL; if (q->size == 0) { q->head = node; q->tail = node; } else { q->tail->next = node; q->tail = node; } q->size++; } // 出队 Element* dequeue(Queue* q) { if (q->size == 0) { return NULL; } QueueNode* node = q->head; Element* e = node->data; q->head = node->next; q->size--; free(node); return e; } // 获取队列大小 int getSize(Queue* q) { return q->size; } // 测试代码 int main() { // 初始化队列 Queue q; init(&q); // 入队 Element e1 = { 1, "Alice" }; Element e2 = { 2, "Bob" }; enqueue(&q, &e1); enqueue(&q, &e2); // 出队 Element* e = dequeue(&q); printf("Dequeued element: %d, %s\n", e->id, e->name); free(e); // 获取队列大小 printf("Queue size: %d\n", getSize(&q)); return 0; } ``` 在上面的示例代码中,我们定义了一个名为`Element`的结构体,它包含一个整型的`id`和一个指向字符数组的指针`name`。然后,我们定义了一个名为`QueueNode`的队列节点结构体,它包含一个指向`Element`的指针`data`和一个指向下一个节点的指针`next`。接着,我们定义了一个名为`Queue`的队列结构体,它包含一个指向队列头节点的指针`head`、一个指向队列尾节点的指针`tail`和一个整型的`size`表示队列大小。最后,我们实现了初始化队列、入队、出队和获取队列大小等基本操作函数,并且在`main`函数中对这些函数进行了简单的测试。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值