More is better 查并集 并且找最大连通分量

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 34171    Accepted Submission(s): 12094


 

Problem Description

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

 

 

Input

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

 

 

Output

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

 

 

Sample Input

 

4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8

 

 

Sample Output

 
4 2

Hint

 

#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
int a[10000001],b[100001];
struct kk
{
    int l,r;
}s[100001];
int cmp(int x,int y)
{
    return x>y;
}
int find(int x)
{
    int r=x,j;
    while(x!=a[x])
    x=a[x];
    while(r!=x)
    {
        j=a[r];
        a[r]=x;
        r=j;
    }
    return x;
}
int join(int x,int y)
{
    int fx=find(x);
    int fy=find(y);
    if(fx!=fy)
    {
        a[fy]=a[fx];     从今天开始,fy就是我a[fx]派的啦
        b[a[fx]]+=b[fy];               你派的人马也归我了
        return 1;
    }
    else
    return 0;
}
int main()
{
    int n,x,y,i,j,t;
    while(~scanf("%d",&n))
    {
        int m=0;
        if(n==0)
        {
            cout<<1<<endl;
            continue;
        }
        t=0;
        int max=0;
        memset(b,0,sizeof(b));
        for(i=1;i<=n;i++)
        {
            cin>>s[i].l>>s[i].r;
            if(s[i].l>max)
            max=s[i].l;
            if(s[i].r>max)
            max=s[i].r;
        }
        for(i=1;i<=max;i++)
        {
            a[i]=i;            
            b[i]=1;           原始武林 ,各成一派
        }
        
        for(i=1;i<=n;i++)
        {
            join(s[i].l,s[i].r);
        }
        for(i=1;i<=max;i++)
        {
            if(b[i]>m)              找最大帮派
            {
                m=b[i];
            }
        }
        cout<<m<<endl;
        
        
        
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值