What day is it 用基姆拉尔森计算公式算

What day is it

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7699    Accepted Submission(s): 2189


 

Problem Description

Today is Saturday, 17th Nov,2007. Now, if i tell you a date, can you tell me what day it is ?

 

 

Input

There are multiply cases.
One line is one case.
There are three integers, year(0<year<10000), month(0<=month<13), day(0<=day<32).

 

 

Output

Output one line.
if the date is illegal, you should output "illegal". Or, you should output what day it is.

 

 

Sample Input

 

2007 11 17

 

 

Sample Output

 

Saturday

 

 

Author

LGX

 

 

Source

HDU 2007-11 Programming Contest_WarmUp

 

 

Recommend

威士忌   |   We have carefully selected several similar problems for you:  2136 2135 2137 2134 21

注意不合法的情况,m,d,y必须都大于1,

基姆拉尔森计算公式:

基姆拉尔森计算公式

W= (d+2*m+3*(m+1)/5+y+y/4-y/100+y/400+1) mod 7

把一月和二月看成是上一年的十三月和十四月,例:如果是1990-1-1则换算成:1989-13-1来代入公式计算。

 

我还把周六的英文多加了个s

#include<iostream>
using namespace std;
bool leap(int y)
{
    if(y%4==0&&y%100!=0||y%400==0)
    return true;
    else
    return false;
}
int main()
{
    char a[7][15]={"Monday","Tuesday","Wednesday","Thursday","Friday","Saturday","Sunday"};
    int y,m,d,i,j,b[13]={0,31,28,31,30,31,30,31,31,30,31,30,31};
    while(~scanf("%d%d%d",&y,&m,&d))
    {
        if(leap(y))
        b[2]=29;
        if(y>10000||y<1||m<1||m>12||d>b[m]||d<1)
        {
            printf("illegal\n");
            continue;
        }
        if(m<3)
        {
            y--;
            m+=12;
        }
        int w=(d+2*m+3*(m+1)/5+y+y/4-y/100+y/400)%7;    核心在这,基姆拉尔森公式(d+2*m+3*(m+1)/5+y+y/4-y/100+y/400)%7
        printf("%s\n",a[w]);
        b[2]=28;
    }
    return 0;

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值