数据结构实验之栈与队列一:进制转换

数据结构实验之栈与队列一:进制转换
Time Limit: 1000 ms Memory Limit: 65536 KiB
Submit Statistic Discuss
Problem Description

输入一个十进制非负整数,将其转换成对应的 R (2 <= R <= 9) 进制数,并输出。
Input

第一行输入需要转换的十进制非负整数;
第二行输入 R。
Output

输出转换所得的 R 进制数。
Sample Input

1279
8
Sample Output

2377

#include <iostream>

using namespace std;

int main()
{
   int N,R;
   cin>>N;cin>>R;
   int A[100];
   int top=0;
   if(N==0)cout<<N<<endl;
   else
    {
        while(N!=0)
        {
          A[top]=N%R;
          top++;
          N=N/R;
        }
        while(top!=0)
        {
            top--;
            cout<<A[top];
        }

    }

    return 0;
}

#include <stdio.h>
#include <stdlib.h>

int main()
{
    int N,R;
    scanf("%d",&N);
    scanf("%d",&R);
    int A[1000];
    int top=0;
    if(N==0)
    {
        printf("0\n");
    }
    else
    {
        while(N)
        {
            top++;
            A[top]=N%R;
            N=N/R;
        }
        while(top)
        {
            printf("%d",A[top]);
            top--;
        }
    }

    return 0;
}

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <stack>
using namespace std;
int main()
{
    int N,R;
    scanf("%d",&N);
    scanf("%d",&R);
    stack<int>mystack;
    if(N==0)
    {
        printf("0\n");
    }
    else
    {
        while(N)
        {
            mystack.push(N%R);
            N=N/R;
        }
        while(!mystack.empty())
        {
            printf("%d",mystack.top());
            mystack.pop();
        }
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

奈何碎银没有几两

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值