Problem Description
输入一个十进制非负整数,将其转换成对应的 R (2 <= R <= 9) 进制数,并输出。
Input
第一行输入需要转换的十进制非负整数;
第二行输入 R。
Output
输出转换所得的 R 进制数。
Example Input
1279
8
Example Output
2377
Hint
Author
#include <stdio.h>
int main()
{
int t, m, top = -1, a[100000], temp = 0;
scanf ("%d", &m);
scanf ("%d", &t);
while(m)
{
a[++top] = m % t;
m /= t;
}
while(top != -1)
{
temp *= 10;
temp += a[top--];
}
printf ("%d\n", temp);
return 0;
}
先进后出?不存在的(玩笑脸)