SDUT OJ数据结构实验之二叉树的建立与遍历

数据结构实验之二叉树的建立与遍历

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic Discuss

Problem Description

       已知一个按先序序列输入的字符序列,如abc,,de,g,,f,,,(其中逗号表示空节点)。请建立二叉树并按中序和后序方式遍历二叉树,最后求出叶子节点个数和二叉树深度。

 

Input

 输入一个长度小于50个字符的字符串。

Output

输出共有4行:
第1行输出中序遍历序列;
第2行输出后序遍历序列;
第3行输出叶子节点个数;
第4行输出二叉树深度。

Sample Input

abc,,de,g,,f,,,

Sample Output

cbegdfa
cgefdba
3
5

Hint

 

Source

ma6174

#include<cstring>
#include<cstdlib>
#include<cstdio>
#include<iostream>
using namespace std;
typedef struct st
{
    char data;
    st *r,*l;
}tree;
tree *creat(tree *t)
{
    char x;
    cin>>x;
    if(x==',')t=NULL;
    else
    {
        t=new st;
        t->data=x;
        t->l=creat(t->l);
        t->r=creat(t->r);
    }
    return t;
}
void zh(tree *t)
{
    if(t)
    {
        zh(t->l);
        cout<<t->data;
        zh(t->r);
    }
}
void sh(tree *t)
{
    if(t)
    {
        sh(t->l);
        sh(t->r);
        cout<<t->data;
    }
}
int an=0;
void ya(tree *t)
{
    if(t)
    {
        if(t->l==NULL&&t->r==NULL)
        {
            an++;
        }
        else
        {
            ya(t->l);
            ya(t->r);
        }
    }
}
int shen(tree *t)
{
    if(t)
    {
        int l1=shen(t->l)+1;
        int r1=shen(t->r)+1;
        if(l1>r1) return l1;
        else return r1;
    }
    return 0;
}
int main()
{tree *t;
t=NULL;
t=creat(t);
zh(t);
cout<<endl;
sh(t);
cout<<endl;
ya(t);
cout<<an<<endl;
int kk=shen(t);
cout<<kk<<endl;

    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值