PAT (Advanced Level) Practice 1002 A+B for Polynomials (25 分)

 

本来想在原来做的pta博客上再附上java实现的代码,发现这道题没写博客,那只好补发一波了,hhh

题目:

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

 题意:

 多项式计算,给出两个多项式的项数,然后按照指数递减的顺序给出系数和指数。输出最后的项数和各个项的系数和指数。

 思路:

其实就是类似于链表合并操作,坑点是注意系数为0不能出现在结果中。

C++代码:

#include <bits/stdc++.h>
using namespace std;
const int maxn=1e3+5;
int n,m;
struct pol 
{
	int zhi;
	double xi;
};
vector<pol>ans;
pol a[maxn],b[maxn];
int numa=0,numb=0;
int main()
{
	scanf("%d",&n);
	for (int i=0;i<n;i++)
	{
		int zhi;
		double xi;
		scanf("%d%lf",&zhi,&xi);
		if(xi!=0.0)
		{
			a[numa].zhi=zhi;
			a[numa++].xi=xi;
		}
	}
	scanf("%d",&m);
	for (int i=0;i<m;i++)
	{
		int zhi;
		double xi;
		scanf("%d%lf",&zhi,&xi);
		if(xi!=0.0)
		{
			b[numb].zhi=zhi;
			b[numb++].xi=xi;
		}
	}
	int i=0,j=0;
	while (i<numa||j<numb)
	{
		if((j>=numb)||(a[i].zhi>b[j].zhi))
		{
			pol x;
			x.zhi=a[i].zhi; x.xi=a[i].xi;
			ans.push_back(x);
			i++;
		}
		else if((i>=numa)||(b[j].zhi>a[i].zhi))
		{
			pol x;
			x.zhi=b[j].zhi; x.xi=b[j].xi;
			ans.push_back(x);
			j++;
		}
		else if(i<numa&&j<numb&&a[i].zhi==b[j].zhi)
		{
			pol x;
			x.zhi=a[i].zhi; x.xi=a[i].xi+b[j].xi;
			if(x.xi!=0.0)
				ans.push_back(x);
			i++; j++;
		}
	}
	printf("%d",ans.size());
	for (int i=0;i<ans.size();i++)
	{
		printf(" %d %.1lf",ans[i].zhi,ans[i].xi);
	}
	printf("\n");
	return 0;
}

Java 代码:

import java.util.ArrayList;
import java.util.List;
import java.util.Scanner;

/**
 * @classname: Adv1002
 * @description: TODO
 * Author : asus
 * Date : 2019/10/24 20:02
 * Version: 1.0
 **/
public class Main {
    public static void main(String[] args) {
        Scanner sc= new Scanner(System.in);
        int num1 = sc.nextInt();
        List<node> list1 = new ArrayList<>();
        List<node> list2 = new ArrayList<>();
        List<node> rs = new ArrayList<>();
        int re0 = 0;
        for (int i=0;i<num1;i++)
        {
            list1.add(new node(sc.nextInt(),sc.nextDouble()));
        }
        int num2 = sc.nextInt();
        for (int i=0;i<num2;i++)
        {
            list2.add(new node(sc.nextInt(),sc.nextDouble()));
        }
        int i=0,j=0;
        while(i<num1||j<num2)
        {
            if(i<num1&&j<num2)
            {

                if(list1.get(i).x==list2.get(j).x)
                {
                    node temp = new node();
                    temp.x = list1.get(i).x;
                    temp.a = list1.get(i).a+list2.get(j).a;
                    if(temp.a!=0.0) rs.add(temp);
                    i++; j++;
                }
                else if(list1.get(i).x<list2.get(j).x)
                {
                    if(list2.get(j).a!=0.0) rs.add(list2.get(j));
                    j++;
                }
                else
                {
                    if(list1.get(i).a!=0.0) rs.add(list1.get(i));
                    i++;
                }
            }
            else if (i<num1)
            {
                if(list1.get(i).a!=0.0) rs.add(list1.get(i++));
            }
            else
            {
                if(list2.get(j).a!=0.0) rs.add(list2.get(j++));
            }
        }
        System.out.print(rs.size());
        for (int k=0;k<rs.size();k++)
        {
            System.out.print(" "+rs.get(k).x+" "+String.format("%.1f",rs.get(k).a));
        }
        System.out.println();

    }
}
class node
{
    int x;
    double a;

    public node() {
    }

    public node(int x, double a) {
        this.x = x;
        this.a = a;
    }
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值