POJ 1716 Intervals 差分约束

You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn.
Write a program that:
reads the number of intervals, their end points and integers c1, ..., cn from the standard input,
computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i=1,2,...,n,
writes the answer to the standard output.

Input

The first line of the input contains an integer n (1 <= n <= 50000) -- the number of intervals. The following n lines describe the intervals. The (i+1)-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50000 and 1 <= ci <= bi - ai+1.

Output

The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i=1,2,...,n.

Sample Input

5
3 7 3
8 10 3
6 8 1
1 3 1
10 11 1

Sample Output

6

题意:

给出数轴上的n个闭合int型区间。现在要在数轴上任意取一堆元素,构成一个元素集合V,要求给出的每个区间和元素集合V的交集至少有两个不同的元素,求集合V最小的元素个数。

根据题目的信息,我们可以得出d[y]-d[x-1]>=c;

然后我们转换一下:

d[y]>=d[x-1]+c;

不要忘了一下条件:

d[i]-d[i-1]>=0;

d[i]-d[i-1]<=0;

没有这些条件边与边之间是串不起来的。

然后再求最长路就可以了。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <queue>
#include <vector>
using namespace std;
const int maxn=50005;
const int INF=0x3f3f3f3f;
int n;
struct edge
{
    int e,len;
};
vector <edge> ve[maxn];
int d[maxn];
int maxx,minn;
int vis[maxn];
void init()
{
    maxx=-1;
    minn=INF;
    for (int i=0;i<maxn;i++)
        d[i]=-INF;
    for (int i=0;i<maxn;i++)
        ve[i].clear();
    memset (vis,0,sizeof(vis));
}
void spfa()
{
    d[minn]=0;
    queue<int>q;
    q.push(minn);
    while (!q.empty())
    {
        int u=q.front(); q.pop();
        vis[u]=0;
        for (int i=0;i<ve[u].size();i++)
        {
            int v=ve[u][i].e;
            if(d[v]<d[u]+ve[u][i].len)
            {
                d[v]=d[u]+ve[u][i].len;
                if(!vis[v])
                {
                    q.push(v);
                    vis[v]=1;
                }
            }
        }
    }
    printf("%d\n",d[maxx]);
}
int main()
{
    scanf("%d",&n);
    init();
    for (int i=0;i<n;i++)
    {
        int x,y,len;
        scanf("%d%d%d",&x,&y,&len);
        maxx=max(maxx,y);
        minn=min(minn,x-1);
        edge temp;
        temp.e=y; temp.len=len;
        ve[x-1].push_back(temp);
    }
    for (int i=minn+1;i<=maxx;i++)
    {
        edge temp1,temp2;
        temp1.e=i; temp1.len=0;
        temp2.e=i-1; temp2.len=-1;
        ve[i-1].push_back(temp1);
        ve[i].push_back(temp2);
    }
    spfa();
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值