Intervals ZOJ - 1508(差分约束系统)

题目

You are given n closed, integer intervals [ai, bi] and n integers c1, …, cn.

Write a program that:

reads the number of intervals, their endpoints and integers c1, …, cn from the standard input,

computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i = 1, 2, …, n,

writes the answer to the standard output.

Input

The first line of the input contains an integer n (1 <= n <= 50 000) - the number of intervals. The following n lines describe the intervals. The i+1-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50 000 and 1 <= ci <= bi - ai + 1.

Process to the end of file.

Output

The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i = 1, 2, …, n.

Sample Input

5
3 7 3
8 10 3
6 8 1
1 3 1
10 11 1

Sample Output

6

解释

将题目的不等式关系转化为边,但是相邻单整数区间元素要大于0小于1,这两个关系,产生的边很多,用bellman_ford时间花费较多,可以进行优化,将这两个关系直接进行判读,而不是存成边。
先对边进行松弛后,才对这两个关系进行循环判断,减少了后两个关系的更新次数。其实总的边数并没有减少,只是改变了边的排序拿来更新的序列,使得更新更有益。判断次数没有减少,但更新次数少了,耗时就少了,时间复杂度上并没有显著差别。
由于dis[mx] - dis[i] >= 0, dis[mx] = 0, 则有dis[i] - dis[mx] <= 0,得到dis[i] <= 0,故可以初始化距离数组为0,减少更新次数,判断次数不变,稍稍优化。

#include <cstdio>
#include <vector>
#include <algorithm>
#include <cstring>
#define inf 0x3f3f3f3f
#define maxn 50001
using namespace std;
struct Edge {
	int v, u, w;
	Edge(int _u, int _v, int _w):u(_u), v(_v), w(_w){ }
};
int n;
vector<Edge> e;
int dis[maxn];
int mn, mx;
void bellman_ford() {
	memset(dis, 0, sizeof(dis));
	int flag = 1;
	while (flag) {
		flag = 0;
		for (int i = 0; i < n; i++) {
			if (dis[e[i].v] > dis[e[i].u] + e[i].w) {
				dis[e[i].v] = dis[e[i].u] + e[i].w;
				flag = 1;
			}
		}//边数
		for (int i = mn; i <= mx; i++) {
			if (dis[i] > dis[i - 1] + 1) {
				dis[i] = dis[i - 1] + 1;
				flag = 1;
			}
		}
		for (int i = mx; i >= mn; i--) {
			if (dis[i - 1] > dis[i]) {
				dis[i - 1] = dis[i];
				flag = 1;
			}
		}
	}
}
int main() {
	
	int u, v, w;
	while (~scanf("%d", &n)) {
		mx = 1;
		mn = inf;
		e.clear();
		for (int i = 0; i < n; i++) {
			scanf("%d %d %d", &u, &v, &w);
			e.push_back(Edge(v, u - 1, -w));
			mn = min(mn, u);
			mx = max(mx, v);
		}
		bellman_ford();
		printf("%d\n", dis[mx] - dis[mn-1]);
	}

	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值