连通分量 Aizu - ALDS1_11_D Connected Components dfs或bfs或并查集

Write a program which reads relations in a SNS (Social Network Service), and judges that given pairs of users are reachable each other through the network.

Input

In the first line, two integer nn and mm are given. nn is the number of users in the SNS and mm is the number of relations in the SNS. The users in the SNS are identified by IDs 0,1,...,n−10,1,...,n−1 .

In the following mm lines, the relations are given. Each relation is given by two integers ss and tt that represents ss and tt are friends (and reachable each other).

In the next line, the number of queries qq is given. In the following qq lines, qq queries are given respectively. Each query consists of two integers ss and tt separated by a space character.

Output

For each query, print "yes" if tt is reachable from ss through the social network, "no" otherwise.

Constraints

  • 2≤n≤100,0002≤n≤100,000
  • 0≤m≤100,0000≤m≤100,000
  • 1≤q≤10,0001≤q≤10,000

Sample Input

10 9
0 1
0 2
3 4
5 7
5 6
6 7
6 8
7 8
8 9
3
0 1
5 9
1 3

Sample Output

yes
yes
no

此题我一开始用的dfs, 然后超时, 发现需要在查询之前确定是否连通,于是乎想到了并查集。。 。做完发现并查集是真的快。 。dfs写了一遍, 但是不如并查集快。 。。

dfs:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <vector>
using namespace std;
const int maxn=100005;
int n,m,q;
int num;
vector<int>ve[maxn];
int col[maxn];
void init()
{
    num=0;
    memset (col,0,sizeof(col));
}
void dfs(int x,int nm)
{
     col[x]=nm;
     for (int i=0;i<ve[x].size();i++)
     {
         int z=ve[x][i];
         //避免陷入死递归
         if(!col[z])
            dfs(z,nm);
     }
}
void Find ()
{
    for (int i=0;i<n;i++)
        if(!col[i])
            dfs(i,++num);
}
int main()
{
    scanf("%d%d",&n,&m);
    init();
    while (m--)
    {
        int x,y;
        scanf("%d%d",&x,&y);
        ve[x].push_back(y);
        ve[y].push_back(x);
    }
    Find();
    scanf("%d",&q);
    while (q--)
    {
        int x,y;
        scanf("%d%d",&x,&y);
        col[x]==col[y]?printf("yes\n"):printf("no\n");
    }
    return 0;
}

并查集:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <vector>
using namespace std;
const int maxn=100005;
int n,m,q;
int a[maxn];
void init()
{
    for (int i=0;i<n;i++)
        a[i]=i;
}
//寻找父节点
int Find(int x)
{
    if(x==a[x])
        return x;
    return a[x]=Find(a[x]);
}
//合并
void unit (int x,int y)
{
    int parx=Find(x);
    int pary=Find(y);
    if(parx!=pary)
        a[parx]=pary;
}
int main()
{
    scanf("%d%d",&n,&m);
    init();
    while (m--)
    {
        int x,y;
        scanf("%d%d",&x,&y);
        unit(x,y);
    }
    scanf("%d",&q);
    while (q--)
    {
        int x,y;
        scanf("%d%d",&x,&y);
        Find(x)==Find(y)?printf("yes\n"):printf("no\n");
    }
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值