HDU 1452 Happy 2004 因数和

53 篇文章 0 订阅

Problem Description

Consider a positive integer X,and let S be the sum of all positive integer divisors of 2004^X. Your job is to determine S modulo 29 (the rest of the division of S by 29).

Take X = 1 for an example. The positive integer divisors of 2004^1 are 1, 2, 3, 4, 6, 12, 167, 334, 501, 668, 1002 and 2004. Therefore S = 4704 and S modulo 29 is equal to 6.

 

 

Input

The input consists of several test cases. Each test case contains a line with the integer X (1 <= X <= 10000000).

A test case of X = 0 indicates the end of input, and should not be processed.

 

 

Output

For each test case, in a separate line, please output the result of S modulo 29.

 

 

Sample Input

 

1 10000 0

 

 

Sample Output

 

6 10

 

 

Source

ACM暑期集训队练习赛(六)

 代码如下:

/*
此题是求2004^x%29的因子和。。。
首先:
任何一个数可以化成几个素因子幂的乘积的形式。。
2004=2^2*3*167;
这里167这个数字可以化简下,167%29=22;
令g(p, e) = (p^(e+1) - 1) / (p-1), 其中p为素因子,e为素因子的幂
则s(n) = g(p1, e1) * g(p2, e2) * ... * g(pk, ek)。
因此:
因子和可化为:s(2004^n)=[(2^(2n+1)-1)/1]*[(3^(n+1)-1)/2]*[22^(n+1)/21]%29;
这里可以用逆元进行运算
1的逆元为1;
2的逆元为15;
21的逆元为18;
所以式子进一步简化为:
s(2004^n)=(2^(2n+1)-1)*(3^(n+1)-1)*15*(22^(n+1))*18%29;
15*28又能进一步取余
所以最终式子为:
s(2004^n)=(2^(2n+1)-1)*(3^(n+1)-1)*(22^(n+1))*9%29;
*/
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
int n;
int fastpow (int a,int b)
{
    int sum=1;
    while (b>0)
    {
        if(b%2)
        {
            sum=sum*a%29;
        }
        a=a*a%29;
        b>>=1;
    }
    return sum;
}
int main()
{
    while (scanf("%d",&n)!=EOF&&n)
    {
        int a,b,c;
        a=fastpow(2,(n<<1)+1)-1;
        b=fastpow(3,n+1)-1;
        c=fastpow(22,n+1)-1;
        printf("%d\n",9*a*b*c%29);

    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值