HDU 1852 Beijing 2008 因数和+快速幂取模

53 篇文章 0 订阅

Problem Description

As we all know, the next Olympic Games will be held in Beijing in 2008. So the year 2008 seems a little special somehow. You are looking forward to it, too, aren't you? Unfortunately there still are months to go. Take it easy. Luckily you meet me. I have a problem for you to solve. Enjoy your time.

Now given a positive integer N, get the sum S of all positive integer divisors of 2008N. Oh no, the result may be much larger than you can think. But it is OK to determine the rest of the division of S by K. The result is kept as M.

Pay attention! M is not the answer we want. If you can get 2008M, that will be wonderful. If it is larger than K, leave it modulo K to the output. See the example for N = 1,K = 10000: The positive integer divisors of 20081 are 1、2、4、8、251、502、1004、2008,S = 3780, M = 3780, 2008M % K = 5776.
 

 

 

Input

The input consists of several test cases. Each test case contains a line with two integers N and K (1 ≤ N ≤ 10000000, 500 ≤ K ≤ 10000). N = K = 0 ends the input file and should not be processed.

 

 

Output

For each test case, in a separate line, please output the result.

 

 

Sample Input

 

1 10000 0 0

 

 

Sample Output

 

5776

题意:

先求出2008的n次方的因子和m, 然后再求2008的m次幂取余k。 。。

代码如下:

/*
2008=2^3*251;
由于250和k不一定互素,所以不能求出250与k的逆元...
由于x/d%m=x%(d*m)/d;
所以可以对(250*k)进行取余...
最后不要忘了/250;
求出因子和之后就可以用快速幂取模求出2008的m次方...
*/
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
int n,k;
long long int fastpow(long long int a,long long int b,long long int c)
{
    long long int sum=1;
    while (b>0)
    {
        if(b%2)
            sum=sum*a%c;
        a=a*a%c;
        b>>=1;
    }
    return sum;
}
int main()
{
    while (scanf("%d%d",&n,&k)!=EOF&&(n||k))
    {
        long long int a1=fastpow(2,3*n+1,250*k)-1;
        long long int b1=fastpow(251,n+1,250*k)-1;
        long long int m=a1*b1%(250*k)/250;
        printf("%lld\n",fastpow(2008,m,k));
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值