Poj 3641 Pseudoprime numbers 快速幂取模

53 篇文章 0 订阅

Description

Fermat's theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-a pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.

Input

Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a.

Output

For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".

Sample Input

3 2
10 3
341 2
341 3
1105 2
1105 3
0 0

Sample Output

no
no
yes
no
yes
yes

很基础的一道快速幂取模的题目....

只需要判断a^p%p与a%p两个结果是否相等和判断p是否为素数即可...

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <math.h>
using namespace std;
typedef long long ll;
ll p,a;
ll Fast (ll a,ll b)
{
    ll sum=1,mod=b;
    while (b>0)
    {
        if(b&1)
        {
            sum=sum*a%mod;
        }
        b>>=1;
        a=a*a%mod;
    }
    return sum;
}
bool Is_pri (ll x)
{
    if(x==1)
        return false;
    for (int i=2;i<=sqrt(x);i++)
           if(x%i==0)
              return false;
    return true;
}
int main()
{
    while (scanf("%lld%lld",&p,&a)!=EOF&&(p||a))
    {
        ll mod1=a%p;
        ll mod2=Fast(a,p);
        if(mod2==mod1)
        {
            if(Is_pri(p))
                printf("no\n");
            else
                printf("yes\n");
        }
        else
            printf("no\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值