Hdu 1395 2^x mod n = 1 取模运算

53 篇文章 0 订阅

Problem Description

Give a number n, find the minimum x(x>0) that satisfies 2^x mod n = 1.

 

 

Input

One positive integer on each line, the value of n.

 

 

Output

If the minimum x exists, print a line with 2^x mod n = 1.

Print 2^? mod n = 1 otherwise.

You should replace x and n with specific numbers.

 

 

Sample Input

 

2

5

 

 

Sample Output

 

2^? mod 2 = 1

2^4 mod 5 = 1

当n=1||n为偶数时,一定不存在解...

当n为奇数时,一定存在解....

然后用最普通的累成取模就可以过.....

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
int n;
int gcd (int a,int b)
{
    return b==0? a:gcd(b,a%b);
}
int main()
{
    while (scanf("%d",&n)!=EOF)
    {
        if(n==1||n%2==0)
            printf("2^? mod %d = 1\n",n);
        else
        {
            int ans=1,m=2;
            while (m%n!=1)
            {
                m=(m*2)%n;
                ans++;
            }
            printf("2^%d mod %d = 1\n",ans,n);
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值