Hdu 2444 The Accomodation of Students

题目:

There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.

Input

For each data set:
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.
 

Output

If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.

Sample Input

4 4
1 2
1 3
1 4
2 3
6 5
1 2
1 3
1 4
2 5
3 6

Sample Output

No
3

思路:

先判定是否为二分图然后利用匈牙利算法来实现求最大匹配数。

一开始写了个dfs判定是否为二分图,感觉写的很有问题,上网上搜了一下发现都是用bfs写的,感觉还是bfs写起来简单一些。

然后再套用匈牙利算法求最大匹配数就行了。

建图是用的邻接表。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <queue>
using namespace std;
const int maxn=205;
struct edge
{
    int next;
    int to;
}edge[maxn*maxn];
int head[maxn];
int n,m;
int ans;
int col[maxn];
int vis[maxn];
int match[maxn];
void add (int id,int u,int v)
{
    edge[id].to=v;
    edge[id].next=head[u];
    head[u]=id;
}
bool bfs ()
{
    queue<int>q;
    q.push(1);
    col[1]=1;
    while (!q.empty())
    {
        int now=q.front(); q.pop();
        for (int i=head[now];i!=-1;i=edge[i].next)
        {
            int u=edge[i].to;
            if(col[u]==-1)
            {
                col[u]=col[now]^1;
                q.push(u);
            }
            else if(col[u]==col[now]) return false;
        }
    }
    return true;
}
int xfind(int x)
{
    for (int i=head[x];i!=-1;i=edge[i].next)
    {
        int u=edge[i].to;
        if(vis[u]==0)
        {
            vis[u]=1;
            if(match[u]==-1||xfind(match[u]))
            {
                match[u]=x;
                return 1;
            }
        }
    }
    return 0;
}
void arrage()
{
    for (int i=1;i<=n;i++)
    {
        memset (vis,0,sizeof(vis));
        if(xfind(i)) ans++;

    }
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        ans=0;
        int ok=1;
        memset (col,-1,sizeof(col));
        memset (head,-1,sizeof(head));
        memset (match,-1,sizeof(match));
        for (int i=0,j=0;i<m;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            add(++j,x,y);
            add(++j,y,x);
        }
        if(bfs()==false)
        {
            printf("No\n");
            continue;
        }
        arrage();
        printf("%d\n",ans/2);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值