HDU - 3974 Assign the task dfs确定区间+线段树

题目:

There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and all his subordinates are your subordinates as well. If you are nobody's boss, then you have no subordinates,the employee who has no immediate boss is the leader of whole company.So it means the N employees form a tree.

The company usually assigns some tasks to some employees to finish.When a task is assigned to someone,He/She will assigned it to all his/her subordinates.In other words,the person and all his/her subordinates received a task in the same time. Furthermore,whenever a employee received a task,he/she will stop the current task(if he/she has) and start the new one.

Write a program that will help in figuring out some employee’s current task after the company assign some tasks to some employee.

Input

The first line contains a single positive integer T( T <= 10 ), indicates the number of test cases.

For each test case:

The first line contains an integer N (N ≤ 50,000) , which is the number of the employees.

The following N - 1 lines each contain two integers u and v, which means the employee v is the immediate boss of employee u(1<=u,v<=N).

The next line contains an integer M (M ≤ 50,000).

The following M lines each contain a message which is either

"C x" which means an inquiry for the current task of employee x

or

"T x y"which means the company assign task y to employee x.

(1<=x<=N,0<=y<=10^9)

Output

For each test case, print the test case number (beginning with 1) in the first line and then for every inquiry, output the correspond answer per line.

Sample Input

1 
5 
4 3 
3 2 
1 3 
5 2 
5 
C 3 
T 2 1
 C 3 
T 3 2 
C 3

Sample Output

Case #1:
-1 
1 
2

思路:

建立两个数组st和en,分别表示节点所管辖的左右区间,我们可以通过dfs来确定节点的管辖区间范围。

在当前节点x开始搜索到它的儿子们时设置st[x],当访问完自己的儿子节点再设置en[x],这样左右区间就确定下来了。

因为这题是区间更新,所以我们可以设置懒惰标记来提高效率。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <vector>
using namespace std;
const int maxn=5*1e5+5;
int t,n;
int tr[maxn<<2];
int is[maxn];
int vis[maxn];
int head[maxn];
int st[maxn],en[maxn];
int mark[maxn<<2];
int ans;
int cnt;
vector<int>a[maxn];
void dfs (int x)
{
    st[x]=++cnt;
    for (int i=0;i<a[x].size();i++)
    {
        int u=a[x][i];
        dfs(u);
    }
    en[x]=cnt;
}
void push_down(int rt)
{
    if(mark[rt]!=-1)
    {
        mark[rt<<1]=mark[rt];
        mark[rt<<1|1]=mark[rt];
        tr[rt<<1]=mark[rt];
        tr[rt<<1|1]=mark[rt];
        mark[rt]=-1;
    }
}
void build (int l,int r,int rt)
{
    if(l==r)
    {
        tr[rt]=-1;
        return;
    }
    int m=(l+r)>>1;
    build(l,m,rt<<1);
    build(m+1,r,rt<<1|1);
}
void update (int L,int R,int l,int r,int x,int rt)
{
    if(l>=L&&r<=R)
    {
        mark[rt]=x;
        tr[rt]=x;
        return;
    }
    int m=(l+r)>>1;
    push_down(rt);
    if(L<=m) update (L,R,l,m,x,rt<<1);
    if(R>m) update (L,R,m+1,r,x,rt<<1|1);
}
void query (int d,int l,int r,int rt)
{
    if(l==d&&d==r)
    {
        ans=tr[rt];
        return;
    }
    int m=(l+r)>>1;
    push_down(rt);
    if(m>=d) query (d,l,m,rt<<1);
    else query (d,m+1,r,rt<<1|1);
}
int main()
{
    scanf("%d",&t);
    for (int k=1;k<=t;k++)
    {
        cnt=0;
        memset (st,0,sizeof(st));
        memset (en,0,sizeof(en));
        memset (mark,-1,sizeof(mark));
        memset (head,-1,sizeof(head));
        memset (is,0,sizeof(is));
        scanf("%d",&n);
        for (int i=1;i<=n;i++)
            a[i].clear();
        build(1,n,1);
        for (int i=0,j=0;i<n-1;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            is[x]=1;
            a[y].push_back(x);
        }
        for (int i=1;i<=n;i++)
        {
            if(!is[i])
            {
                dfs(i);
                break;
            }
        }
        printf("Case #%d:\n",k);
        int q;
        scanf("%d",&q);
        while(q--)
        {
            char s[2];
            scanf("%s",s);
            if(s[0]=='C')
            {
                int x;
                scanf("%d",&x);
                query(st[x],1,n,1);
                printf("%d\n",ans);
            }
            if(s[0]=='T')
            {
                int x,y;
                scanf("%d%d",&x,&y);
                update (st[x],en[x],1,n,y,1);
            }
        }
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值