ZOJ - 3705 Applications 模拟

题目:

Recently, the ACM/ICPC team of Marjar University decided to choose some new members from freshmen to take part in the ACM/ICPC competitions of the next season. As a traditional elite university in ACM/ICPC, there is no doubt that application forms will fill up the mailbox. To constitute some powerful teams, coaches of the ACM/ICPC team decided to use a system to score all applicants, the rules are described as below. Please note that the score of an applicant is measured by pts, which is short for "points".

1. Of course, the number of solved ACM/ICPC problems of a applicant is important. Proudly, Marjar University have a best online judge system called Marjar Online Judge System V2.0, and in short, MOJ. All solved problems in MOJ of a applicant will be scored under these rules:

  • (1) The problems in a set, called MaoMao Selection, will be counted as 2.5 pts for a problem.
  • (2) The problems from Old Surgeon Contest, will be counted as 1.5 pts for a problem.
  • There is no problem in MaoMao Selection from Old Surgeon Contest.
  • (3) Besides the problem from MaoMao Selection and Old Surgeon Contest, if the problem's id is a prime, then it will be counted as 1 pts.
  • (4) If a solved problem doesn't meet above three condition, then it will be counted as 0.3 pts.

 

2. Competitions also show the strength of an applicant. Marjar University holds the ACM/ICPC competition of whole school once a year. To get some pts from the competition, an applicant should fulfill rules as below:

  • The member of a team will be counted as 36 pts if the team won first prize in the competition.
  • The member of a team will be counted as 27 pts if the team won second prize in the competition.
  • The member of a team will be counted as 18 pts if the team won third prize in the competition.
  • Otherwise, 0 pts will be counted.

 

3. We all know that some websites held problem solving contest regularly, such as JapanJam, ZacaiForces and so on. The registered member of JapanJam will have a rating after each contest held by it. Coaches thinks that the third highest rating in JapanJam of an applicant is good to show his/her ability, so the scoring formula is:

 

Pts = max(0, (r - 1200) / 100) * 1.5

 

Here r is the third highest rating in JapanJam of an applicant.

4. And most importantly - if the applicant is a girl, then the score will be added by 33 pts.

The system is so complicated that it becomes a huge problem for coaches when calculating the score of all applicants. Please help coaches to choose the best M applicants!

Input

There are multiple test cases.

The first line of input is an integer T (1 ≤ T ≤ 10), indicating the number of test cases.

For each test case, first line contains two integers N (1 ≤ N ≤ 500) - the number of applicants and M (1 ≤ M ≤ N) - the number of members coaches want to choose.

The following line contains an integer R followed by R (0 ≤ R ≤ 500) numbers, indicating the id of R problems in MaoMao Selection.

And then the following line contains an integer S (0 ≤ S ≤ 500) followed by S numbers, indicating the id of S problems from Old Surgeon Contest.

The following line contains an integer Q (0 ≤ Q ≤ 500) - There are Q teams took part in Marjar University's competition.

Following Q lines, each line contains a string - team name and one integer - prize the team get. More specifically, 1 means first prize, 2 means second prize, 3 means third prize, and 0 means no prize.

In the end of each test case, there are N parts. In each part, first line contains two strings - the applicant's name and his/her team name in Marjar University's competition, a char sex - M for male, F for female and two integers P (0 ≤ P ≤ 1000) - the number of problem the applicant solved, C (0 ≤ C ≤ 1000) - the number of competitions the applicant have taken part in JapanJam.

The following line contains P integers, indicating the id of the solved problems of this applicant.

And, the following line contains C integers, means the rating for C competitions the applicant have taken part in.

We promise:

  • The problems' id in MaoMao Selection, Old Surgeon Contest and applicant's solving list are distinct, and all of them have 4 digits (such as 1010).
  • All names don't contain spaces, and length of each name is less than 30.
  • All ratings are non-negative integers and less than 3500.

 

Output

For each test case, output M lines, means that M applicants and their scores. Please output these informations by sorting scores in descending order. If two applicants have the same rating, then sort their names in alphabet order. The score should be rounded to 3 decimal points.

Sample Input

1
5 3
3 1001 1002 1003
4 1004 1005 1006 1007
3
MagicGirl!!! 3
Sister's_noise 2
NexusHD+NexusHD 1
Edward EKaDiYaKanWen M 5 3
1001 1003 1005 1007 1009
1800 1800 1800
FScarlet MagicGirl!!! F 3 5
1004 1005 1007
1300 1400 1500 1600 1700
A NexusHD+NexusHD M 0 0


B None F 0 0


IamMM Sister's_noise M 15 1
1001 1002 1003 1004 1005 1006 1007 1008 1009 1010 1011 1012 1013 1014 1015
3000

Sample Output

FScarlet 60.000
IamMM 44.300
A 36.000

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <vector>
#include <map>
using namespace std;
const int maxn=1e4+5;
int t;
int n,m;
int vis[maxn];
int pri[maxn];
map<string,int>un;
struct stu
{
    string name;
    double score;
};
stu st[1005];
void judge ()
{
    for (int i=2;i<maxn;i++)
    {
        if(pri[i]==0)
        {
            for (int j=i*i;j<maxn;j+=i) pri[j]=1;
        }
    }
}
int compare1(int a,int b)
{
    return a>b;
}
int compare2(stu a,stu b)
{
    if(a.score!=b.score) return a.score>b.score;
    return a.name<b.name;
}
int main()
{
    memset (pri,0,sizeof(pri));
    ios::sync_with_stdio(false);
    cout.tie(NULL);
    judge();
    cin>>t;
    while(t--)
    {
        un.clear();
        memset (vis,0,sizeof(vis));
        cin>>n>>m;
        int num;
        cin>>num;
        for (int i=0;i<num;i++)
        {
            int x;
            cin>>x;
            vis[x]=1;
        }
        cin>>num;
        for (int i=0;i<num;i++)
        {
            int x;
            cin>>x;
            vis[x]=2;
        }
        cin>>num;
        for (int i=0;i<num;i++)
        {
            string s;
            int x;
            cin>>s>>x;
            un[s]=x;
        }
        for (int i=0;i<n;i++)
        {
            string sex,from;
            int num1,num2;
            st[i].score=0;
            cin>>st[i].name>>from>>sex>>num1>>num2;
            if(sex[0]=='F') st[i].score+=33;
            if(un[from]==1) st[i].score+=36;
            if(un[from]==2) st[i].score+=27;
            if(un[from]==3) st[i].score+=18;
            for (int j=0;j<num1;j++)
            {
                int x;
                cin>>x;
                if(vis[x]==1) st[i].score+=2.5;
                else if(vis[x]==2) st[i].score+=1.5;
                else if(pri[x]==0) st[i].score+=1.0;
                else st[i].score+=0.3;
            }
            vector<int> v;
            for (int j=0;j<num2;j++)
            {
                int x;
                cin>>x;
                v.push_back(x);
            }
            if(num2>=3)
            {
                sort(v.begin(),v.end(),compare1);
                st[i].score+=max(0.0,(v[2]-1200)*1.0/100.0)*1.5;
            }
        }
        sort(st,st+n,compare2);
        for (int i=0;i<m;i++)
        {
            printf("%s %.3lf\n",st[i].name.c_str(),st[i].score);
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值