LightOJ - 1259 Goldbach`s Conjecture 素数筛

题目:

Goldbach's conjecture is one of the oldest unsolved problems in number theory and in all of mathematics. It states:

Every even integer, greater than 2, can be expressed as the sum of two primes [1].

Now your task is to check whether this conjecture holds for integers up to 107.

Input

Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case starts with a line containing an integer n (4 ≤ n ≤ 107, n is even).

Output

For each case, print the case number and the number of ways you can express n as sum of two primes. To be more specific, we want to find the number of (a, b) where

1)      Both a and b are prime

2)      a + b = n

3)      a ≤ b

Sample Input

2

6

4

Sample Output

Case 1: 1

Case 2: 1

Note

1.      An integer is said to be prime, if it is divisible by exactly two different integers. First few primes are 2, 3, 5, 7, 11, 13, ...

思路:

先用素数筛求出1e7中的素数,然后枚举素数。

注意,开判定是否为素数的数组一定要设置成bool类型,不然会报MLE。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
typedef long long ll;
const ll maxn=1e7+5;
int t,n;
bool is[maxn];
int cnt=0;
int pri[664590];
void judge ()
{
    for (int i=2;i<maxn;i++)
    {
        if(is[i]==false)
        {
            pri[cnt++]=i;
            for (int j=i*2;j<maxn;j+=i) is[j]=true;
        }
    }
}
int main()
{

    for (int i=0;i<maxn;i++) is[i]=false;
    judge();
    scanf("%d",&t);
    int Case=0;
    while(t--)
    {
        Case++;
        scanf("%d",&n);
        int num=0;
        for (int i=0;i<cnt;i++) {
                if(pri[i]>n/2) break;
                if(is[n-pri[i]]==false) num++;
        }
        printf("Case %d: %d\n",Case,num);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值