Goldbach`s Conjecture LightOJ - 1259(筛素数)

Goldbach`s Conjecture

LightOJ - 1259

Goldbach's conjecture is one of the oldest unsolved problems in number theory and in all of mathematics. It states:

Every even integer, greater than 2, can be expressed as the sum of two primes [1].

Now your task is to check whether this conjecture holds for integers up to 107.


Input

Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case starts with a line containing an integer n (4 ≤ n ≤ 107, n is even).

Output

For each case, print the case number and the number of ways you can express n as sum of two primes. To be more specific, we want to find the number of (a, b) where

1)      Both a and b are prime

2)      a + b = n

3)      a ≤ b

Sample Input

2

6

4

Sample Output

Case 1: 1

Case 2: 1

Note

1.      An integer is said to be prime, if it is divisible by exactly two different integers. First few primes are 2, 3, 5, 7, 11, 13, ...

这道题本身没有什么难度,但是这道题有几个点卡你
1.筛素数后要把素数存下来遍历素数,如果直接遍历会超时
2.筛素数时判断素数的数组要开1e7+1毫无疑问,因为要筛选这么多素数,但是存素数的数组如果也开这么大就内存超限了。。
所以要开小一点1e6就过了
好坑
code:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 1e7+1;
const int N = 1e6;
bool isprime[maxn];
int cnt;
int prime[N];
void init(){
    memset(isprime,true,sizeof(isprime));
    cnt = 0;
    isprime[0] = isprime[1] = false;
    for(int i = 2; i < maxn; i++){
        if(isprime[i]){
            prime[cnt++] = i;
            for(int j = i + i; j < maxn; j += i){
                isprime[j] = false;
            }
        }
    }
}
int main(){
    init();
    int t,cas = 0;
    scanf("%d",&t);
    while(t--){
        int n;
        scanf("%d",&n);
        int ans = 0;
        for(int i = 0; i < cnt && prime[i] <= n/2; i++){
            if(isprime[n-prime[i]]) ans++;
        }
        printf("Case %d: %d\n",++cas,ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值