SCU4438 Censor(字符串哈希)

http://acm.scu.edu.cn/soj/problem.action?id=4438

Censor

frog is now a editor to censor so-called sensitive words (敏感词).

She has a long text pp. Her job is relatively simple -- just to find the first occurence of sensitive word ww and remove it.

frog repeats over and over again. Help her do the tedious work.

Input

The input consists of multiple tests. For each test:

The first line contains 11 string ww. The second line contains 11 string pp.

(1≤length of w,p≤5⋅1061≤length of w,p≤5⋅106, w,pw,p consists of only lowercase letter)

Output

For each test, write 11 string which denotes the censored text.

Sample Input

    abc
    aaabcbc
    b
    bbb
    abc
    ab

Sample Output

    a
    
    ab

非常好的一道题

s数组模拟栈,如果出现敏感词汇,top-= len ,从top开始覆盖

#include <bits/stdc++.h>
using namespace std;
using lon = unsigned long long;

const int N = 5e6 + 5;
const lon base = 7;
lon h[N], h_w, h_p[N];
char s[N];
string p, w;
int top = 0;

int main()
{
	h[0] = 1;
	for(int i = 1; i < N; i++) h[i] = h[i-1] * base;

	while(cin >> w >> p)
	{
		h_w = 0; top = 0;
		for(int i = 0; i < w.length(); i++)
		h_w = h_w * base + w[i];
		
		for(int i = 0; i < p.length(); i++)
		{
			s[top++] = p[i];
			h_p[top] = h_p[top-1] * base + p[i];
			
			if(top >= w.length() && h_p[top] - h_p[top-w.length()] * h[w.length()] == h_w)
			 top -= w.length();
		}
		
		s[top] = '\0';
		cout << s << endl;
	}
	
	return 0;
}
/*
abc
aaabcbc
b
bbb
abc
ab
    */

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值