1038 Recover the Smallest Number (30 分)

1038 Recover the Smallest Number (30 分)
Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:
Each input file contains one test case. Each case gives a positive integer N (≤10
​4
​​ ) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

题目大意就是用给定的数字组合出一个最小数字,并且最前面的0不能输出。
乍一看好像没啥难的,不就是个排序问题么?这还真就是个排序问题,不过不能只按照字典序来排,题目要求组合出最小数字,相当于组合成最小的字符串,这时候就体现出sort()函数第三个参数的强大之处了。sort()函数的前两个参数分别为待排序序列的起始位置和终止位置,默认按字典序排序,传入第三个参数可以自定义排序规则。按照题目要求我们应该按照组合后最小来排序。个人觉得这个题用字符串来做比较方便。将排好序后的各个字符串拼接成一个字符串,查找其中第一个不为0的字符,若找不到则说明为全0串,直接输出0即可;找到了就从第一个不为0的字符开始一直输出到最后即可。

#include <iostream>
#include <string>
#include <algorithm>

using namespace std;

bool compare(string a, string b) {//按照拼接后最小排序
	string x = a + b;
	string y = b + a;
	return x < y;
}

int main()
{
	int n;
	cin >> n;
	string num[10001];
	for (int i = 0; i < n; i++)
		cin >> num[i];
	sort(num, num + n, compare);

	string result = "";
	for (int i = 0; i < n; i++)
		result = result + num[i];

	int index = result.find_first_not_of("0");//查找第一个不为0的字符
	if (index == -1) {//找不到,为全0串,输出0
		cout << 0 << endl;
		return 0;
	}

	result = result.substr(index);//找到了,提取从第一个不为0的字符到最后的子串输出
	cout << result << endl;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
ECDSA.recover is a function in the ECDSA (Elliptic Curve Digital Signature Algorithm) cryptographic system that allows a user to recover the public key from a given signature and message. This function is useful in situations where the public key is unknown but the signature and message are available. The ECDSA algorithm involves three steps: key generation, signature generation, and signature verification. In the key generation step, a private key is generated using a random number generator, and the corresponding public key is derived from the private key. In the signature generation step, a message is hashed and signed using the private key to generate a signature. In the signature verification step, the signature is verified using the public key to ensure that it was generated by the owner of the private key. In some cases, the public key may not be available, but the signature and message are known. In such cases, the ECDSA.recover function can be used to recover the public key from the signature and message. The function takes three inputs: the message, the signature, and the recovery parameter. The recovery parameter is a number between 0 and 3 that specifies which of the four possible public keys should be recovered from the signature. Once the public key is recovered, it can be used to verify the signature and authenticate the message. Overall, ECDSA.recover is a useful function in the ECDSA cryptographic system that allows for public key recovery in situations where it is unknown but the signature and message are available.

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值