拓扑序列--HDU 2647

Reward

Dandelion’s uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a’s reward should more than b’s.Dandelion’s unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work’s reward will be at least 888 , because it’s a lucky number.

Input
One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a’s reward should be more than b’s.

Output
For every case ,print the least money dandelion ‘s uncle needs to distribute .If it’s impossible to fulfill all the works’ demands ,print -1.

Sample Input

2 1
1 2
2 2
1 2
2 1

Sample Output

1777
-1

题目大意:老板发工资,但是有一定的要求,输入a b,即a的工资一定要比b高,以此类推,求老板最低可以发多少工资?每个人最低发888
拓扑序列问题,从出度为0的节点开始,每个与其相邻的节点的工资都比它多1,每次算完该节点,就把下一个节点的出度减一,如果出度为0,则入队列。
因为需要遍历每一层,需要用队列,类似于广搜,还需要用拓扑排序,判断能否构成有向无环图。

#include<iostream>
#include<queue>
#include<vector>
#include<climits>
#include<cstring>
using namespace std;
const int MAXN=10001;

vector<int> graph[MAXN];
int outDegree[MAXN];

void  TopologicalSort(int n)
{
	int sum=0;  //返回最后的结果 
	int now=888;//记录每一层的数值 
	int cnt=0;
	queue<int> myQ;
	for(int i=1;i<=n;i++)
	{
		if(outDegree[i]==0)  //把出度为0的入队列
		myQ.push(i);
	}
	while(!myQ.empty())
	{
		int qsize=myQ.size();
		while(qsize--)
		{
			int u=myQ.front();
			myQ.pop();
			cnt++; 
			sum+=now;
			for(int i=0;i<graph[u].size();i++)
			{
				int v=graph[u][i];
				outDegree[v]--;
				if(outDegree[v]==0)
				myQ.push(v);
			}
		}
		now++;//每加一层,数值便加1
		
	}
	if(cnt==n)//可以构成有向无环图
	cout<<sum<<endl;
	else
	cout<<-1<<endl;
	
}
int main()
{
	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		memset(graph,0,sizeof(graph));
		memset(outDegree,0,sizeof(outDegree));
		while(m--)
		{
			int a,b;
			scanf("%d%d",&a,&b);
			graph[b].push_back(a);
			outDegree[a]++;
		}
		TopologicalSort(n);
		
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值