数据结构实验复习

1 顺序建立链表

题目描述

输入N个整数,按照输入的顺序建立单链表存储,并遍历所建立的单链表,输出这些数据。

输入

第一行输入整数的个数N;
第二行依次输入每个整数。

输出

输出这组整数。

示例输入

8
12 56 4 6 55 15 33 62

示例输出

12 56 4 6 55 15 33 62

#include<stdio.h>
#include<iostream>
using namespace std;
struct node
{
    int  d;
    node *next;
};
node *CreatList(int n)      //顺序建表,尾插法 
{
    node *head=new node;
    head->next=NULL;
    node *tail=head;//tail是指向head的指针 
    for(int i=0;i<n;i++)
    {
        node *p=new node ;
        cin>>p->d;
        tail->next=p;
        tail=p;
    }
    tail->next=NULL;
    return head;
}
void PrintList(node *head)  //输出链表
{
    node *p=head->next;
    while(p!=NULL)
    {
        if(p->next==NULL)
            cout<<p->d<<endl;
        else
            cout<<p->d<<" ";
        p=p->next;
    }
}
int main()
{
    int n;
    cin>>n;
    node *head=NULL;
    head=CreatList(n);
    PrintList(head);
    return 0;
}

2.栈的使用

有效的括号

#include <iostream>
#include <stack>
#include <string.h>
using namespace std;
int mai
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值