1 顺序建立链表
题目描述
输入N个整数,按照输入的顺序建立单链表存储,并遍历所建立的单链表,输出这些数据。
输入
第一行输入整数的个数N;
第二行依次输入每个整数。
第二行依次输入每个整数。
输出
输出这组整数。
示例输入
8 12 56 4 6 55 15 33 62
示例输出
12 56 4 6 55 15 33 62
#include<stdio.h>
#include<iostream>
using namespace std;
struct node
{
int d;
node *next;
};
node *CreatList(int n) //顺序建表,尾插法
{
node *head=new node;
head->next=NULL;
node *tail=head;//tail是指向head的指针
for(int i=0;i<n;i++)
{
node *p=new node ;
cin>>p->d;
tail->next=p;
tail=p;
}
tail->next=NULL;
return head;
}
void PrintList(node *head) //输出链表
{
node *p=head->next;
while(p!=NULL)
{
if(p->next==NULL)
cout<<p->d<<endl;
else
cout<<p->d<<" ";
p=p->next;
}
}
int main()
{
int n;
cin>>n;
node *head=NULL;
head=CreatList(n);
PrintList(head);
return 0;
}
2.栈的使用
有效的括号
#include <iostream>
#include <stack>
#include <string.h>
using namespace std;
int mai