ZOJ 1094:Matrix Chain Multiplication(栈)

题目链接

Matrix multiplication problem is a typical example of dynamical programming.

Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose.
For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix.
There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).
The first one takes 15000 elementary multiplications, but the second one only 3500.

Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.

Input Specification

Input consists of two parts: a list of matrices and a list of expressions.
The first line of the input file contains one integer n (1 <= n <= 26), representing the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix.
The second part of the input file strictly adheres to the following syntax (given in EBNF):

 

SecondPart = Line { Line } <EOF>
Line       = Expression <CR>
Expression = Matrix | "(" Expression Expression ")"
Matrix     = "A" | "B" | "C" | ... | "X" | "Y" | "Z"

 

Output Specification

For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.

Sample Input

9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))

Sample Output

0
0
0
error
10000
error
3500
15000
40500
47500
15125

题意分析:

给出n个矩阵的行数和列数, 求给出式子需要计算多少次乘法。

解题思路:

字符串中存在3种情况:

1.左括号:不用计算

2.右括号:取出两个矩阵计算乘法次数,把新的矩阵入栈

3.矩阵名:把矩阵入栈

两个矩阵 x*y 只有当x的列和y的行相等时才能进行运算,

新的矩阵行和x的行相等, 列和y的列相等。

x.r 是矩阵x的行数, x.l是矩阵x的列数,

每计算矩阵的一个值需要进行 x.l 次乘法,新的矩阵一共有x.r*y.l 个元素, 所以每一次进行矩阵乘法需要进行

x.l * x.r * y.l 次乘法。

#include <bits/stdc++.h>
using namespace std;
struct date {
	int r;                        //行 
	int l;                        //列 
};
map<char, date>maps;
stack<date>s; 
char str[1020];
int main()
{
	char ch;
	int n;
	scanf("%d", &n);
	for(int i=0; i<n; i++) {
		getchar();
		scanf("%c", &ch);
		scanf("%d%d", &maps[ch].r, &maps[ch].l);
	}
	while(scanf("%s", str)!=EOF) {
		while(!s.empty())
			s.pop();
		int ans=0;
		int i;
		for(i=0; i<strlen(str); i++) {
			if(str[i]=='(')
				continue;
			if(str[i]==')') {
				date y=s.top();
				s.pop();
				date x=s.top();
				s.pop();
				if (x.l!=y.r) {
					printf("error\n");
					break;
				} 
				ans+=x.r*x.l*y.l;
				date z;
				z.r=x.r;
				z.l=y.l;
				s.push(z);
			}
			else {
				date x = maps[str[i]];
				s.push(x);
			}
		}
		if(i==strlen(str))
			printf("%d\n", ans);
	}
	return 0;
} 

 

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

张宜强

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值