POJ 2115:C Looooops(exgcd)

题目链接

Description

A Compiler Mystery: We are given a C-language style for loop of type

for (variable = A; variable != B; variable += C)

  statement;


I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2k) modulo 2k.
 

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2k) are the parameters of the loop.

The input is finished by a line containing four zeros.

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate.

Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766
FOREVER

题意分析:

初始值是a, 每次循环加c,并且对2^{k}取余,直到变为b结束,问需要循环多少次。

解题思路:

设需要循环x次,则一共加了c*x,最后变为b的时候结束,则

            (c*x)% 2^{k} = b-a,

即          c*x = (b-a)(mod 2^{k}), 可以用扩展欧几里得求x。

#include <stdio.h>
long long x, y;
long long exgcd(long long a, long long b)
{
	if(b==0) {
		x=1;
		y=0;
		return a;
	}
	long long d = exgcd(b, a%b);
	long long temp=x;
	x=y;
	y=temp-a/b*y;
	return d;
}
int main()
{
	long long a, b, c, k;
	while(scanf("%lld%lld%lld%lld", &a, &b, &c, &k)!=EOF)
	{
		if(a==0 && b==0 && c==0 && k==0)
			break;
		long long n = 1ll<<k;
		long long d = exgcd(c, n);
		b=b-a;
		if(b%d) {
			printf("FOREVER\n");
			continue;
		}
		long long ans = b/d*x;
		long long t = n/d;
		printf("%lld\n", ((ans%t+t)%t));
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

张宜强

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值