hdu1054:Strategic Game(最小点覆盖)

72 篇文章 0 订阅
30 篇文章 0 订阅

http://acm.hdu.edu.cn/showproblem.php?pid=1054

Problem Description

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

The input file contains several data sets in text format. Each data set represents a tree with the following description:

the number of nodes
the description of each node in the following format
node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifier
or
node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500). Every edge appears only once in the input data.

For example for the tree:



the solution is one soldier ( at the node 1).

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following table:

 

 

Sample Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output

1
2

题意分析:

有一个城市包含多条路线,在每个点可以派士兵驻守,驻守的士兵可以守护与这个点相连的道路,问最少需要多少士兵。

解题思路:

最小点覆盖的定义:假如选了一个点就相当于覆盖了以它为端点的所有边。最小顶点覆盖就是选择最少的点来覆盖所有的边。

最大独立集=总数-最小点覆盖,

最小点覆盖=最大匹配数。

#include <stdio.h>
#include <vector>
#include <string.h>
#define N 1520
using namespace std;
vector<int>e[N];
int m[N], n, book[N];
int dfs(int u)
{
	int k, i;
	k=e[u].size();
	for(i=0; i<k; i++)
	{
		if(!book[e[u][i]])
		{
			book[e[u][i]]=1;
			if(m[e[u][i]]==-1 || dfs(m[e[u][i]]))
			{
				m[e[u][i]]=u;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int i,ans, u, v, t;
	while(scanf("%d", &n)!=EOF)
	{
		memset(m, -1, sizeof(m));
		for(i=0; i<n; i++)
			e[i].clear();
		for(i=0; i<n; i++)
		{
			scanf("%d:(%d)", &u, &t);
			while(t--)
			{
				scanf("%d", &v);
				e[u].push_back(v);
				e[v].push_back(u);
			}
		}
		ans=0;
		for(i=0; i<n; i++)
		{
			memset(book, 0, sizeof(book));
			if(dfs(i))
				ans++;
		}
		printf("%d\n", ans/2);
	}
	return 0;
} 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

张宜强

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值