hdu1533:Going Home(KM匹配)

72 篇文章 0 订阅
30 篇文章 0 订阅

http://acm.hdu.edu.cn/showproblem.php?pid=1533

Problem Description

On a grid map there are n little men and n houses. In each unit time, every little man can move one unit step, either horizontally, or vertically, to an adjacent point. For each little man, you need to pay a $1 travel fee for every step he moves, until he enters a house. The task is complicated with the restriction that each house can accommodate only one little man.

Your task is to compute the minimum amount of money you need to pay in order to send these n little men into those n different houses. The input is a map of the scenario, a '.' means an empty space, an 'H' represents a house on that point, and am 'm' indicates there is a little man on that point.

You can think of each point on the grid map as a quite large square, so it can hold n little men at the same time; also, it is okay if a little man steps on a grid with a house without entering that house.

 

 

Input

There are one or more test cases in the input. Each case starts with a line giving two integers N and M, where N is the number of rows of the map, and M is the number of columns. The rest of the input will be N lines describing the map. You may assume both N and M are between 2 and 100, inclusive. There will be the same number of 'H's and 'm's on the map; and there will be at most 100 houses. Input will terminate with 0 0 for N and M.

 

 

Output

For each test case, output one line with the single integer, which is the minimum amount, in dollars, you need to pay.

 

 

Sample Input

2 2
.m
H.
5 5
HH..m
.....
.....
.....
mm..H
7 8
...H....
...H....
...H....
mmmHmmmm
...H....
...H....
...H....
0 0

 

 

Sample Output

2
10
28

题意分析:

给出一个地图,m代表男人,H代表房子,每个男人向周围移动一次需要支付1美金,每个房子只能进入一个男人,求所有男人都到达房子需要支付的最少金币。

解题思路:

把每个男人和房子之间的距离存下来,KM匹配算法。

#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;
#define N 120
struct data{
	int x;
	int y;
}h[N], man[N];
int e[N][N], lx[N], ly[N], bookx[N], booky[N], march[N], slack[N], nx, ny, inf=99999999;
char str[N][N];
int dfs(int u)
{
	bookx[u]=1;
	int v, t;
	for(v=1; v<=ny; v++)
	{
		if(booky[v]==0)
		{
			t=lx[u]+ly[v]-e[u][v];
			if(t==0)
			{
				booky[v]=1;
				if(march[v]==0 || dfs(march[v]))
				{
					march[v]=u;
					return 1;
				}
			}
			else
				slack[v]=min(t, slack[v]);
		}
	}
	return 0;
}
int KM()
{
	int i, j, x, d;
	memset(march, 0, sizeof(march));
	memset(ly, 0, sizeof(ly));
	for(i=1; i<=nx; i++)
	{
		lx[i]=-inf;
		for(j=1; j<=ny; j++)
			lx[i]=max(lx[i], e[i][j]);	
	}	
	for(x=1; x<=nx; x++)
	{
		for(i=1; i<=ny; i++)
			slack[i]=inf;
		while(1)
		{
			memset(bookx, 0, sizeof(bookx));
			memset(booky, 0, sizeof(booky));
			if(dfs(x))
				break;
			d=inf;
			for(i=1; i<=ny; i++)
				if(!booky[i])
					d=min(d, slack[i]);
			for(i=1; i<=nx; i++)
				if(bookx[i])
					lx[i]-=d;
			for(i=1; i<=ny; i++)
				if(booky[i])
					ly[i]+=d;
				else
					slack[i]-=d;
		}
	} 
	int sum=0;
	for(i=1; i<=ny; i++)
		if(march[i])
			sum+=e[march[i]][i];
	return -sum;
} 
int main()
{
	int n, m, i, j;
	while(scanf("%d%d", &n, &m)!=EOF)
	{
		if(m==0 && n==0)
			break;
		for(i=1; i<=n; i++)
			for(j=1; j<=m; j++)
				e[i][j]=-inf;
		for(i=0; i<n; i++)
			scanf("%s", str[i]);
		nx=0;ny=0;
		for(i=0; i<n; i++)
		{
			for(j=0; j<m; j++)
			{
				if(str[i][j]=='m')
				{
					nx++;
					man[nx].x=i;
					man[nx].y=j;
				}
				if(str[i][j]=='H')
				{
					ny++;
					h[ny].x=i;
					h[ny].y=j;	
				}	
			}
		}
		for(i=1; i<=nx; i++)
			for(j=1; j<=ny; j++)
				e[i][j]=-abs(man[i].x-h[j].x)-abs(man[i].y-h[j].y);
		printf("%d\n", KM());
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

张宜强

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值