hdu 3549:Flow Problem(最大流)

72 篇文章 0 订阅
19 篇文章 0 订阅

http://acm.hdu.edu.cn/showproblem.php?pid=3549

Problem Description

Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.

 

 

Input

The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)

 

 

Output

For each test cases, you should output the maximum flow from source 1 to sink N.

Sample Input

2
3 2
1 2 1
2 3 1
3 3
1 2 1
2 3 1
1 3 1

 

Sample Output

Case 1: 1
Case 2: 2

题意分析:

求1到n的最大流。

FF算法:

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <vector>
using namespace std;
#define N 20
int book[N];
int n, m, inf=0x3f3f3f;
struct edge {
	int v; 
	int w;
	int rev;
};
vector<edge>e[N];
int dfs(int s, int t, int f)
{
	if (s==t)
		return f;
	book[s] = 1;
	int u, v, d;
	for (v = 0; v < e[s].size(); v++)
	{
		edge &G = e[s][v];
		if (G.w && !book[G.v])
		{
			d = dfs(G.v,t, min(f, G.w));
			if (d > 0)
			{
				G.w -= d;
				e[G.v][G.rev].w += d;
				return d;
			}
				
		}
	}
	return 0;
}
int FF(int s, int t)
{
	int d, sum = 0;
	while (1)
	{
		memset(book, 0, sizeof(book));
		d = dfs(s, t, inf);
		if (d == 0)
			break;
		sum += d;
	}
	return sum;
}
int main()
{
	int t = 0, T, u, v, w, i;
	scanf("%d", &T);
	while (T--)
	{
		scanf("%d%d", &n, &m);
		for (i = 1; i <= n; i++)
			e[i].clear();
		while (m--)
		{
			scanf("%d%d%d", &u, &v, &w);
			e[u].push_back(edge{v, w, e[v].size()});
			e[v].push_back(edge{u, 0, e[u].size()-1});
		}
		printf("Case %d: %d\n", ++t, FF(1, n));
	}
	return 0;
}

EK算法:

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
using namespace std;
#define N 20
int e[20][20], pre[N], flow[N];
int n, m, inf=0x3f3f3f;
queue<int>q;
int bfs(int s, int t)
{
	int u, v;
	while (!q.empty())
		q.pop();
	memset(pre, -1, sizeof(pre));
	flow[s] = inf;
	q.push(s);
	while (!q.empty())
	{
		u = q.front();
		q.pop();
		if (u == t)
			break;
		for (v=1; v<=n; v++)
			if (pre[v] == -1 && v != s && e[u][v])
			{
				pre[v] = u;
				q.push(v);
				flow[v] = min(flow[u], e[u][v]);
			}
	}
	if (pre[t] == -1)
		return -1;
	return flow[t];
}
int EK(int s, int t)
{
	int d, p, sum=0;
	while (1)
	{
		d = bfs(s, t);
		if (d == -1)
			break;
		p = t;
		while (p != s)
		{
			e[pre[p]][p] -= d;
			e[p][pre[p]] += d;
			p = pre[p];
		}
		sum += d;
	}
	return sum;
}
int main()
{
	int t = 0, T, u, v, w;
	scanf("%d", &T);
	while (T--)
	{
		scanf("%d%d", &n, &m);
		memset(e, 0, sizeof(e));
		while (m--)
		{
			scanf("%d%d%d", &u, &v, &w);
			e[u][v] += w;
		}
		printf("Case %d: %d\n", ++t, EK(1, n));
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

张宜强

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值