ZOJ 2412:Farm Irrigation(DFS)

http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=1412

Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.


Figure 1

Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map

ADC
FJK
IHE

then the water pipes are distributed like


Figure 2

Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn.

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him?

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.

Input

There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.

Output

For each test case, output in one line the least number of wellsprings needed.

Sample Input

2 2
DK
HF

3 3
ADC
FJK
IHE

-1 -1

Sample Output

2
3

题意分析:

有一个n*m个正方形的农场,每个农场会有一种管道铺设方式,只有两块地有管道相通的时候,两者之间可以输水,现在要求所有的地都能有水灌溉,至少应该修建几个水井。

解题思路:

首先把11个管道的铺设方式写出来,四个数代表四个方向,1代表这个方向能够流水,0代表不通。

对于每一块地,遍历他的四个方向,如果这个方向能走且下一块地也有管道通向这一块地,就可以把两块地染成同一颜色,

例如·样例1中, K有管道到F,但是F没有相应的管道来接受,所以这种是不符合条件的。

最后输出颜色的总数即可。

#include <stdio.h>
#include <string.h>
#define N 55
char str[N][N];
int n, m, color[N][N];
int nex[11][4]={{1, 0, 0, 1}, {1, 1, 0, 0}, {0, 0, 1, 1},{0, 1, 1, 0}, 
				{1, 0, 1, 0}, {0, 1, 0, 1}, {1, 1, 0, 1}, {1, 0, 1, 1}, 
				{0, 1, 1, 1}, {1, 1, 1, 0}, {1, 1, 1, 1}    
			};//上右下左四个方向是否能走
void dfs(int x, int y, int col)
{
	int nt[4][2]={{-1, 0}, {0, 1}, {1, 0}, {0, -1}};//上右下左四个方向
	int tx, ty;
	int a=str[x][y]-'A';
	for(int i=0; i<4;i++)
	{
		if(nex[a][i])
		{	
			tx=x+nt[i][0];
			ty=y+nt[i][1];
			if(tx<0 || ty<0 || tx>=n || ty>=m)
				continue;
			
			if(color[tx][ty]==0)
			{
				if((i==0 && nex[str[tx][ty]-'A'][2]==1)
				|| (i==1 && nex[str[tx][ty]-'A'][3]==1)
				|| (i==2 && nex[str[tx][ty]-'A'][0]==1)
				|| (i==3 && nex[str[tx][ty]-'A'][1]==1)) //判断是否连通
				{
					color[tx][ty]=col;
					dfs(tx, ty, col);	
				}
				
			}
		}
	}
}
int main()
{
	int i, j, ans;
	while(scanf("%d%d", &n, &m)!=EOF)
	{
		if(m==-1 && n==-1)
			break;
		memset(color, 0, sizeof(color));
		for(i=0; i<n; i++)
			scanf("%s", str[i]);
		ans=0;
		for(i=0; i<n; i++)
			for(j=0; j<m; j++)
			{
				if(color[i][j]==0)
				{
					ans++;
					dfs(i, j, ans);
				}		
			}
		printf("%d\n", ans);	
	}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

张宜强

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值