hdu 2709:Sumsets(递推)

69 篇文章 0 订阅
34 篇文章 0 订阅

http://acm.hdu.edu.cn/showproblem.php?pid=2709

Problem Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).

 

 

Input

A single line with a single integer, N.

 

 

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

题意分析:

只使用整数幂为2的数字拼凑数字,求一个有多少种可能。

解题思路:

一个奇数,可能数和比它小1的数相同,

比如9和8,把它分成1和8,8那一部分就是a[8],而这边的1不能再操作。

一个偶数8分成1和77那一部分是a[7],再加上一个1

从1 1 2 2 2 开始,变成2 2 2 2,后面的情况就像是4个1来组成4一样,有a[4]种,即a[i/2]。

所以有公式i为奇数时:  a[i]=a[i-1];

                  i为偶数时:  a[i]=a[i-1]+a[i/2];     

#include <stdio.h>
#define N 1000020
int a[N];
int main()
{
	int n;
	a[1]=1;
	for(int i=2; i<N; i++)
		if(i%2==1)
			a[i]=a[i-1];
		else
			a[i]=(a[i-1]+a[i/2])%1000000000; 
	while(scanf("%d", &n)!=EOF)
		printf("%d\n", a[n]);
	return 0;
} 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

张宜强

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值