LightOJ - 1122 :Digit Count (DFS)

https://vjudge.net/contest/317762#problem/L

Given a set of digits S, and an integer n, you have to find how many n-digit integers are there, which contain digits that belong to S and the difference between any two adjacent digits is not more than two.

Input

Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case contains two integers, m (1 ≤ m < 10) and n (1 ≤ n ≤ 10). The next line will contain m integers (from 1 to 9) separated by spaces. These integers form the set S as described above. These integers will be distinct and given in ascending order.

Output

For each case, print the case number and the number of valid n-digit integers in a single line.

Sample Input

3

3 2

1 3 6

3 2

1 2 3

3 3

1 4 6

Sample Output

Case 1: 5

Case 2: 9

Case 3: 9

Note

For the first case the valid integers are

11

13

31

33

66

题意分析:

给出m个数,要求组合成n位数,且相邻两位之间的差不超过2.

解题思路:

直接深搜,对于每一位只考虑前一位的相差2以内的数。

#include <stdio.h>
#include <math.h>
#include <algorithm>
#define N 15
using namespace std;
int a[N];
int n, m, ans;

void dfs(int x, int len)
{
	if(len==n)
	{
		ans++;
		return ;	
	}	
	for(int i=x-2; i<=x+2; i++)
	{
		if(i<0 || i>=m)
			continue;	

		if(abs(a[x]-a[i])<=2)
			dfs(i, len+1);				
	}	
	return ;
}
int main()
{
	int t=0, T;
	scanf("%d", &T);
	while(T--)
	{
		scanf("%d%d", &m, &n);
		for(int i=0; i<m; i++)
			scanf("%d", &a[i]);
		ans=0;
		for(int i=0; i<m; i++)
			dfs(i, 1);
		printf("Case %d: %d\n", ++t, ans);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

张宜强

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值