Problem Description
refresh最近发了一笔横财,开了一家停车场。由于土地有限,停车场内停车数量有限,但是要求进停车场的车辆过多。当停车场满时,要进入的车辆会进入便道等待,最先进入便道的车辆会优先
进入停车场,而且停车场的结构要求只出去的车辆必须是停车场中最后进去的车辆。现告诉你停车场容量N以及命令数M,以及一些命令(Add num 表示车牌号为num的车辆要进入停车场或便道,
Del 表示停车场中出去了一辆车,Out 表示便道最前面的车辆不再等待,放弃进入停车场)。假设便道内的车辆不超过1000000.
Input
输入为多组数据,每组数据首先输入N和M(0< n,m <200000),接下来输入M条命令。
Output
输入结束后,如果出现停车场内无车辆而出现Del或者便道内无车辆而出现Out,则输出Error,否则输出停车场内的车辆,最后进入的最先输出,无车辆不输出。
Sample Input
2 6 Add 18353364208 Add 18353365550 Add 18353365558 Add 18353365559 Del Out
Sample Output
18353365558 18353364208
Hint
Source
AC代码(栈与队列的结合记得要初始化)
#include <iostream>
#include <bits/stdc++.h>
using namespace std;
int main()
{
int n, m, h, f = 1;
char b[10];
while(scanf("%d%d",&n, &m)!=EOF)
{
f = 1;
stack<string>s;
queue<string>q;
string d, a; //初始化,不然把定义放在里面不然就要初始化
while(m--)
{
cin>>b;
if(b[0]=='A')
{
cin>>a;
h = s.size();
if(h==n)
{
q.push(a);
}
else
{
s.push(a);
}
}
else if(b[0]=='D')
{
if(!s.empty())
{
s.pop();
if(!q.empty())
{
s.push(q.front());
q.pop();
}
}
else
f = 0;
}
else
{
if(!q.empty())
{
q.pop();
}
else
f = 0;
}
}
if(f==0)
printf("Error\n");
else
{
while(!s.empty())
{
cout<<s.top()<<endl;
s.pop();
}
}
}
return 0;
}
/***************************************************
Result: Accepted
Take time: 0ms
Take Memory: 196KB
****************************************************/