MagicBuilding

MagicBuilding

Time Limit : 1000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 21   Accepted Submission(s) : 7
Problem Description
As the increase of population, the living space for people is becoming smaller and smaller. In MagicStar the problem is much worse. Dr. Mathematica is trying to save land by clustering buildings and then we call the set of buildings MagicBuilding. Now we can treat the buildings as a square of size d, and the height doesn't matter. Buildings of d1,d2,d3....dn can be clustered into one MagicBuilding if they satisfy di != dj(i != j).
Given a series of buildings size , you need to calculate the minimal numbers of MagicBuildings that can be made. Note that one building can also be considered as a MagicBuilding.
Suppose there are five buildings : 1, 2, 2, 3, 3. We make three MagicBuildings (1,3), (2,3), (2) .And we can also make two MagicBuilding :(1,2,3), (2,3). There is at least two MagicBuildings obviously.
 

Input
The first line of the input is a single number t, indicating the number of test cases. Each test case starts by n (1≤n≤10^4) in a line indicating the number of buildings. Next n positive numbers (less than 2^31) will be the size of the buildings.
 

Output
For each test case , output a number perline, meaning the minimal number of the MagicBuilding that can be made.
 

Sample Input
 
 
2 1 2 5 1 2 2 3 3
 

Sample Output
 
 
1 2
 

Author
scnu
 输出重复个数的最大值

代码如下:

#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
    int t,n,a[10010],i,j,s[10010];
    cin>>t;
    while(t--)
    {
        cin>>n;
        for(i=0; i<n; i++)
        {
            cin>>a[i];
            s[i]=1;
        }
        sort(a,a+n);
        j=0;
        for(i=0; i<n-1; i++)
        {
            if(a[i]==a[i+1])
            {
                s[j]++;
            }
            else
                j++;
        }
        sort(s,s+j+1);
        cout<<s[j]<<endl;
    }
    return 0;

}

注意:这里的代码要求数组定义10^4,所以数组定义一定要超过10^4

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值