HDU 2192 MagicBuilding

http://acm.hdu.edu.cn/showproblem.php?pid=2192

 

MagicBuilding

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 576    Accepted Submission(s): 253


Problem Description
As the increase of population, the living space for people is becoming smaller and smaller. In MagicStar the problem is much worse. Dr. Mathematica is trying to save land by clustering buildings and then we call the set of buildings MagicBuilding. Now we can treat the buildings as a square of size d, and the height doesn't matter. Buildings of d1,d2,d3....dn can be clustered into one MagicBuilding if they satisfy di != dj(i != j).
Given a series of buildings size , you need to calculate the minimal numbers of MagicBuildings that can be made. Note that one building can also be considered as a MagicBuilding.
Suppose there are five buildings : 1, 2, 2, 3, 3. We make three MagicBuildings (1,3), (2,3), (2) .And we can also make two MagicBuilding :(1,2,3), (2,3). There is at least two MagicBuildings obviously.
 

Input
The first line of the input is a single number t, indicating the number of test cases.
Each test case starts by n (1≤n≤10^4) in a line indicating the number of buildings. Next n positive numbers (less than 2^31) will be the size of the buildings.
 

Output
For each test case , output a number perline, meaning the minimal number of the MagicBuilding that can be made.
 

Sample Input
2 1 2 5 1 2 2 3 3
 

Sample Output
1 2
 

Author
scnu
 

Recommend
lcy
 
题意:给出一组数据,找出其中相同数字出现次数的最大值。
分析:感觉是一道简单题,我用哈希做得,一直是running time error 实在是找不出问题。请帮忙看看,到底是哪里出错了。
代码如下:
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
int haxi[10050];
int main()
{
    int T,n,w,k,max,i;
    scanf("%d",&T);
    while(T--)
    {
      scanf("%d",&n);
      memset(haxi,0,sizeof(haxi));
      max=0;
      while(n--)
      {
        scanf("%d",&w);
        haxi[w]++;
    if(max<w) max=w;   
      }
      max=max+1;
        sort(haxi,haxi+max);
      printf("%d\n",haxi[max-1]);
    }
    return 0; 
}
 
最后只能换一种方法,哈希是用不了了。网上找到一个
(其实我感觉使用哈希应该比他的巧妙一点点。。。^-^)
代码如下:

#include <iostream>
#include <algorithm>
using namespace
std;

int
main()
{

    int
t;
    int
n, i;
    int
a[10001];
    scanf("%d", &t);
    while
(t--) {
        scanf("%d", &n);
        for
(i = 0; i < n; ++i) {
            scanf("%d", &a[i]);
        }

        sort(a, a+n);
    int
len = 1;
    for
(i = 1; i < n; ++i) {
        if
(a[i] == a[i-len]) len++;
    }

    printf("%d\n", len);
    }

    return
0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值