hdu 1164

Eddy's interest is very extensive, recently he is interested in prime number. Eddy discover the all number owned can be divided into the multiply of prime number, but he can't write program, so Eddy has to ask intelligent you to help him, he asks you to write a program which can do the number to divided into the multiply of prime number factor .
 

Input

The input will contain a number 1 < x<= 65535 per line representing the number of elements of the set.

Output

You have to print a line in the output for each entry with the answer to the previous question.

Sample Input

11

9412

Sample Output

11

2*2*13*181

#include<iostream>
#include<algorithm>
using namespace std;
int prime(int a)//判断素数
{
    int i;
    for(i=2;i*i<=a;i++)
    {
        if(a%i==0)
            return 0;
    }
    return 1;
}
int main()
{
    int a,i,j,n;
    while(cin>>a)
    {
        if(prime(a))//如果是素数直接输出
            cout<<a<<endl;
        else
        {
            int i=2;
            while(i<=a)//循环条件
            {
                if(a%i==0)//先以2*2*2*2...的形式除尽所有偶数素数因子
                {
                    if(a==i)
                        cout<<a<<endl;//如果出现8=2*2*2的情况
                    else
                        cout<<i<<"*";
                    a=a/i;
                }
                else
                {
                    i++;//剩下只有奇数素数因子,找出即可
                    continue;
                }
            }
        }
    }
    return 0;
}
 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值