算法笔记3.1 问题 E: Shortest Distance (20)

本题为算法笔记一书的课后练习题。

OJ地址为: 点这里跳转

问题描述

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

输入

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 … DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

输出

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

样例输入

5 1 2 4 14 9
3
1 3
2 5
4 1

样例输出

3
10
7

限制

时间限制 : 1.000 sec 内存限制 : 32 MB

思路

所有点成一个环
点 i 到 j 的路径有两条,合起来刚好一圈,所以这两条路径的和是永远固定的。
故:
1.在数据读入时计算出这个和记为 sum
2.读入 i 和 j ,比较大小,若 i > j 交换顺序。
3.计算 i 到 j 的路径和,具体算法是该范围内数据相加,得到answer。
4. 3中得到的数和 sum/2 进行比较,若 answer 较大(即走了远路), 更新answer = sum - answer
5. 输出answer
6.代码如下:

#include<cstdio>
const int MAX=1e5+3;
int a[MAX];
int main(){
	int n,m;
	
	scanf("%d",&n);
	int sum=0;
	for(int i=0;i<n;i++){
		scanf("%d",&a[i]);
		sum += a[i];
	}
	scanf("%d",&m);
	while(m--){
		int num1,num2;
		scanf("%d %d",&num1,&num2);
		if(num1>num2){
			int temp=num1;
			num1=num2;
			num2=temp;
		}
		int answer=0;
		for(int i=num1-1;i<num2-1;i++){
			answer += a[i];
		}
		if(answer > sum/2){
			answer = sum-answer;
		}
		printf("%d\n",answer);
	}
	
	return 0;
}
本地样例通过,提交爆TLE

分析思路,进行优化,当m比较大时,每次求 answer 都要使用反复求某段区间的距离。 m*O(N)的复杂度。

在读数据过程中,对数据进行处理,用 for 循环 a[i]来表示第一个点到第i个点的距离,这样求 i j 之间的距离时可用 a[j] - a[i] 求。时间复杂度降到m*O(1),总体复杂度为 max{O(n), O(m)}

优化后代码如下

#include<cstdio>
const int MAX=1e5+3;
int a[MAX];
int main(){
	int n,m;
	
	scanf("%d",&n);
	int sum=0;
	for(int i=0;i<n;i++){
		scanf("%d",&a[i]);
		sum += a[i];
		a[i] = sum-a[i];
	}
	scanf("%d",&m);
	while(m--){
		int num1,num2;
		scanf("%d %d",&num1,&num2);
		if(num1>num2){
			int temp=num1;
			num1=num2;
			num2=temp;
		}
		int answer=0;
		
		answer = a[num2-1] - a[num1-1];
		
		if(answer > sum/2){
			answer = sum-answer;
		}
		printf("%d\n",answer);
	}
	
	return 0;
}

提交通过~

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值