PTA_甲_1002 A+B for Polynomials

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N
​1
​​ a
​N
​1
​​
​​ N
​2
​​ a
​N
​2
​​
​​ … N
​K
​​ a
​N
​K
​​
​​

where K is the number of nonzero terms in the polynomial, N
​i
​​ and a
​N
​i
​​
​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N
​K
​​ <⋯<N
​2
​​ <N
​1
​​ ≤1000.

Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:
3 2 1.5 1 2.9 0 3.2

代码:

import java.io.BufferedReader;
import java.io.InputStreamReader;

public class Main {

public static void main(String[] args) throws Exception {
    BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
    String[] aLine = br.readLine().trim().split(" ");//trim去首尾空格 split根据空格分割字符串
    String[] bLine = br.readLine().trim().split(" ");
    int A=Integer.parseInt(aLine[0]);//string类型转换为整型
    int B=Integer.parseInt(bLine[0]);
    int maxsize = 1005;
    int count = 0;//记录多项式个数
    double []sum = new double[maxsize];//数组下标为指数,值为系数,所以用double
    for(int i=1,j=1;i<=A;i++)
    {
        int n = Integer.parseInt(aLine[j++]);
        double value = Double.parseDouble(aLine[j++]);
        sum[n]+=value;
    }
    for(int i=1,j=1;i<=B;i++)
    {
        int n = Integer.parseInt(bLine[j++]);
        double value = Double.parseDouble(bLine[j++]);
        sum[n]+=value;//指数相同系数相加
    }
    for(int i=0;i<maxsize;i++)
    {
        if(sum[i]!=0)
        {
            count++;
        }
    }
    System.out.print(count);
    for(int i=maxsize-1;i>=0;i--)
    {
        if(sum[i]!=0)
        {
            System.out.print(" "+i+" "+String.format("%.1f",sum[i]));//打印系数不为0的多项式,保留一位小数
        }
    }


}

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值