首先这道题需积累的单词(- -):
polynomial:
- 英 /,pɒlɪ'nəʊmɪəl/
- 美 /,pɑlɪ'nomɪəl/
-
adj. 多项的,多词的;多项式的
n. 多项式;多词拉丁学名;表示任何多项数之和
exponent:
- 英 /ɪkˈspəʊnənt/
- 美 /ɪkˈspoʊnənt/
-
n. [数] 指数;典型;说明者,说明物
n. 倡导者,鼓吹者,代表者,拥护者
adj. 说明的
coefficient:
- 英 /ˌkəʊɪˈfɪʃnt/
- 美 /ˌkoʊɪˈfɪʃnt/
-
n. [数] 系数;率;协同因素
adj. 合作的;共同作用的
Please be accurate to 1 decimal place:请精确到小数点后1位。
1002 A+B for Polynomials (25分)
This time, you are supposed to find A+B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N1 aN1 N2 aN2 ... NK aNK
where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK<⋯<N2<N1≤1000.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 2 1.5 1 2.9 0 3.2
#include<cstdio>
const int maxn=1005;
double exp[maxn]= {};
int main() {
int k1;
scanf("%d",&k1);
int e;
double c;
while(k1--) {
scanf("%d%lf",&e,&c);
exp[e]+=c;
}
int k2;
scanf("%d",&k2);
while(k2--) {
scanf("%d%lf",&e,&c);
exp[e]+=c;
}
int num=0;
for(int i=0; i<maxn; i++) {
if(exp[i]!=0)
num++;
}
printf("%d",num);
for(int i=maxn; i>=0; i--) {
if(exp[i]!=0.0) {
printf(" %d %.1f",i,exp[i]);
}
}
return 0;
}
测试点1实在是坑了我一波- -问题在哪呢?
当for循环遍历的时候,边界值或初始值(比如int i) 必 须 和你开的数组大小一样!!
当初开了个1005的数组,遍历的时候第一个for循环写了个i<1000;第二个for循环写了个int i=999为初始条件- -
这都是无法通过测试点1的原因,真是无语
所以吸取教训吧。。。直接在上面定义const int maxn就完事了,省着出问题= =