第一行包含两个整数N、M,表示共有N个元素和M个操作。
接下来M行,每行包含三个整数Zi、Xi、Yi
当Zi=1时,将Xi与Yi所在的集合合并
当Zi=2时,输出Xi与Yi是否在同一集合内,是的话输出Y;否则话输出N
输出格式:
如上,对于每一个Zi=2的操作,都有一行输出,每行包含一个大写字母,为Y或者N
输入样例#1:
4 7
2 1 2
1 1 2
2 1 2
1 3 4
2 1 4
1 2 3
2 1 4
输出样例#1:
N
Y
N
Y
并查集:主要是一个并和查的操作,通过记录同类的信息,使一个查询时间变为o(1)
#include <iostream>
using namespace std;
const int N = 1e6 + 10;
int n,m;
int a[N];
int f[N];
int sum;
void ini(){
for(int i = 1; i <= n; i++){
f[i] = i;
}
}
int find(int x){
if(f[x] == x) return x;
return f[x] = find(f[x]);
}
int main(){
cin >> n >> m;
ini();
int type,x,y;
for(int i = 0; i < m; i++){
cin >> type >> x >> y;
if(type == 1){
f[find(x)] = find(y);
}else{
if(find(x) == find(y) ){
cout << "Y" << endl;
}else cout << "N" << endl;
}
}
return 0;
}
/*
4 7
2 1 2
1 1 2
2 1 2
1 3 4
2 1 4
1 2 3
2 1 4
*/